Bug 249570 - cupsd hangs when printing to remote classes
cupsd hangs when printing to remote classes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups (Show other bugs)
5.0
All Linux
low Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-25 11:39 EDT by Dr Philip J Naylor
Modified: 2009-01-20 16:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:59:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CUPS Bugs and Features 2228 None None None Never

  None (edit)
Description Dr Philip J Naylor 2007-07-25 11:39:02 EDT
Description of problem:
Cannot print to remote classes.

Version-Release number of selected component (if applicable):
cups-1.2.4-11.5.1.el5

How reproducible:
Completely.

Steps to Reproduce:
1.  Configure one machine as a print server (i.e. allow remote connections), 
    and create a class (e.g. "color") with at least one printer assigned to it.
2.  Configure second machine with "BrowsePoll print-server-name:631" in
    /etc/cups/cupsd.conf
3.  On second machine do   lpr -Pcolor some.file
  
Actual results:
cupsd stops responding on the client machine.  You have to stop the cups 
daemon, remove job files from /var/spool/cups, then start cups daemon again.
Failing to remove the job files just causes it to hang again straight away.

Expected results:
some.file should print on the printer assigned to class "color".

Additional info:
This is a known bug, involving an infinite loop, in CUPS 1.2.x versions upto 
and including 1.2.7, see 
<http://www.cups.org/str.php?L2228+P0+S0+C0+I10+E0+M10+Qclass>

N.B. versions 1.2.8 through 1.2.10 don't hang when printing to remote classes,
but they don't produce any output on the printer either.  Versions 1.2.11 and
later seem to be fine.
Comment 2 Enrico Scholz 2007-08-01 16:06:34 EDT
ditto here with cups-1.2.4-11.5.3
Comment 6 RHEL Product and Program Management 2008-06-02 16:34:53 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Phil Knirsch 2008-06-13 09:33:56 EDT
Granting Devel ACK.

Read ya, Phil
Comment 10 Kostas Georgiou 2008-10-07 10:45:35 EDT
Just hit this under cups-1.2.4-11.18.el5_2.1, since there is a patch available it would be nice if it can be added for the next update
Comment 13 errata-xmlrpc 2009-01-20 16:59:09 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0201.html

Note You need to log in before you can comment on or make changes to this bug.