Bug 249616 - fence_ipmilan -h suggests self for deprecated option "-i"
Summary: fence_ipmilan -h suggests self for deprecated option "-i"
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
low
low
Target Milestone: ---
: ---
Assignee: Jim Parsons
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-25 19:20 UTC by Vinny Valdez
Modified: 2009-04-16 22:54 UTC (History)
2 users (show)

Fixed In Version: RHBA-2008-0347
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 15:46:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0347 normal SHIPPED_LIVE cman bug fix and enhancement update 2008-05-20 12:39:41 UTC

Description Vinny Valdez 2007-07-25 19:20:51 UTC
Description of problem:
When running "fence_ipmilan -h" the option for -i reads as follows:
-i <ipaddr>    IPMI Lan IP to talk to (deprecated, use -i)
This option is suggesting itself as a replacement since it is deprecated.

Version-Release number of selected component (if applicable):
cman-2.0.60-1.el5

How reproducible:
Always with cman-2.0.60-1.el5

Steps to Reproduce:
1. Install cman-2.0.60-1.el5
2. Type "fence_ipmilan -h"
3. View the line for the option "-i"
  
Actual results:
Help text displayed suggests using "-i" since "-i" is deprecated

Expected results:
This line should read:
-i <ipaddr>    IPMI Lan IP to talk to (deprecated, use -a)

Additional info:
The -i option is missing from the man page, not sure if that is intentional or not.

Comment 1 Jim Parsons 2007-09-12 15:01:30 UTC
all set.

Comment 2 RHEL Product and Program Management 2007-10-23 16:24:40 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 5 errata-xmlrpc 2008-05-21 15:46:40 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0347.html



Note You need to log in before you can comment on or make changes to this bug.