Bug 24962 - gimp hangs on startup
gimp hangs on startup
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gimp (Show other bugs)
7.0
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-25 15:52 EST by Robert M. Riches Jr.
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-25 16:40:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert M. Riches Jr. 2001-01-25 15:52:29 EST
Gimp hangs on startup.  X event processing is even hung, because
it won't refresh the startup window when occluded and then
exposed.  The startup window says it is loading the yinyang plug-in.
An strace says it is waiting for a child:

<... wait4 resumed> [WIFSIGNALED(s) && WTERMSIG(s) == SIGRT_16], WNOHANG,
NULL) = 365

A 'ps augxw' says there's an xsane process apparently started by
gimp.  However, manually running xsane works fine.

Thanks.

Robert Riches
richesr1@inetarena.com
Comment 1 Matt Wilson 2001-01-25 15:54:32 EST
if you uninistallx sane and xsane, does the gimp not hang?
Comment 2 Robert M. Riches Jr. 2001-01-25 16:40:09 EST
Yes, if I uninstall (rpm --erase) all the sane and xsane packages, gimp comes up
without hanging.  That would seem to imply that this report should be
reclassified
to sane/xsane, unless the problem is in the method by which gimp calls xsane.

(I'll need to reinstall sane/xsane, because I need the scanner more than I need
gimp at the moment, but I'll look for a way to locally disable gimp from trying
to
call xsane for now.)

Thanks.

Robert Riches
richesr1@inetarena.com
Comment 3 Robert M. Riches Jr. 2001-09-17 13:37:53 EDT
Reporter confirms this problem is fixed in RH7.1.

Note You need to log in before you can comment on or make changes to this bug.