Bug 249643 - libmtp only usable by root.
Summary: libmtp only usable by root.
Status: CLOSED DUPLICATE of bug 249026
Alias: None
Product: Fedora
Classification: Fedora
Component: libmtp   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Linus Walleij
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-26 00:45 UTC by Gian Paolo Mureddu
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-27 06:41:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gian Paolo Mureddu 2007-07-26 00:45:45 UTC
Description of problem:
After some updates in the past days, libmtp is only usable by root. Users get a
a rather cryptic message that the operation is not permitted:

usb_claim_interface(): Operation not permitted

This results in a LIBMTP panic and inability to use the library or any
applications that make use of it (such as Amarok)

Version-Release number of selected component (if applicable):
libmtp-0.1.5-1.fc7

How reproducible:
always

Steps to Reproduce:
1. Applay latest updates
2. try to run mtp-detect
3.
  
Actual results:
libmtp is useless for regular users

Expected results:
libmtp to be used by regular users.

Additional info:

Comment 1 Gian Paolo Mureddu 2007-07-26 01:00:55 UTC
Apparently the new kernel is at fault here, just booted into the previous 2.6.21
kernel and everything seems to be OK now... Strange that the kernel might be the
root of this problem, though.

Comment 2 Linus Walleij 2007-07-27 06:30:56 UTC
I think we're seeing bug 249026 manifest itself due to renaming of
the subsystem.

Comment 3 Linus Walleij 2007-07-27 06:41:44 UTC

*** This bug has been marked as a duplicate of 249026 ***


Note You need to log in before you can comment on or make changes to this bug.