Bug 249657 - sgml-common rpm build often fails (@mkdir_p@: command not found)
sgml-common rpm build often fails (@mkdir_p@: command not found)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sgml-common (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-26 04:28 EDT by Jos Vos
Modified: 2013-04-12 15:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-22 17:09:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jos Vos 2007-07-26 04:28:35 EDT
Description of problem:
When doing it several times, building the sgml-common rpm fails in about 25% of
all cases with this error:

/bin/sh: @mkdir_p@: command not found

I guess this is related to a s timing issue with file timestamps (but I didn't
thoroughly investigate it).

Version-Release number of selected component (if applicable):
0.6.3-18

Additional info:

In Fedora (0.6.3-20) aclocal and automake commands are replaced by various file
"touches".  Also, when (in the RHEL5 spec file) you insert "autoconf" between
"aclocal" and "automake", the build seems to succeed in 100% of all cases.  But
the spec file as it is now seems to be wrong.
Comment 1 RHEL Product and Program Management 2007-12-03 15:44:41 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 2 RHEL Product and Program Management 2009-11-06 13:44:18 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 7 Ondrej Vasik 2011-06-22 17:09:46 EDT
I'm going to close this bugzilla wontfix. It's quite late in RHEL-5 release cycle and probability of sgml-common update is very low to zero. Issue with parallel builds and timing issue build fails should be fixed in RHEL-6.

Note You need to log in before you can comment on or make changes to this bug.