Bug 24967 - Permedia 2 + X 4.0.2-1 only works with NoAccel + unresolved symbols
Permedia 2 + X 4.0.2-1 only works with NoAccel + unresolved symbols
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-01-25 16:44 EST by Dries Verachtert
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-04-16 05:10:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dries Verachtert 2001-01-25 16:44:53 EST
XFree86 4.0 only works with NoAccel option. XFree86 3.3.6 works but crashes
sometimes. The following errors are reported by the Xserver on startup with
the NoAccel option:

Symbol XAAMoveDWORDS_FixedBase from module
/usr/X11R6/lib/modules/drivers/glint_drv.o is unresolved!
Symbol XAAMoveDWORDS from module /usr/X11R6/lib/modules/drivers/glint_drv.o
is unresolved!

System info:
stock redhat 7.0 + redhat 7.0 updates + rawhide rpms of kde2, gnome,
XFree86, enlightenment + all rawhide rpms needed for dependencies.
version: XFree86-4.0.2-1
system: personal workstation 500au, alpha ev56
video card: Gloria Synergy Permedia 2, Glint.o module
recognized as: Texas Instruments TVP4020 Permedia 2 (rev 1).
Comment 1 Mike A. Harris 2001-01-28 10:52:57 EST
I've asked upstream for any known fixes for this problem.  Awaiting info..
Comment 2 Mike A. Harris 2001-04-02 12:23:39 EDT
I have patches from Compaq but nobody with the hardware so far
that is willing to test them in a timely fashion.  You game?
Comment 3 Mike A. Harris 2001-04-10 01:01:50 EDT
A *MAJOR* new update to the Permedia driver has just been incorporated
into XFree86-4.0.3-8.  The patches are from Compaq, and fix numerous
problems on Alpha, as well as other platforms.  These packages are available
for download at:   http://people.redhat.com/mharris
Please close the bug report after confirming that it does in fact fix the
problem for you, and ensure that you fill out new bug reports if you encounter
any new errors.  Thanks.
Comment 4 Dries Verachtert 2001-04-12 17:05:52 EDT
I'm back :-) 
Sorry for the late reaction, i've been away awhile.
I've upgraded everthing to the latest rpms in rawhide yesterday: 
  downloaded everything, 
  did an rpm -Fvh *.rpm
  rebooted so i'm running 2.4.2 from rawhide

first tested XFree86 4.0:
XFree86 4.0 (from XFree86-4.0.3-5) worked a few minutes and then crashed
I was still able to log in from another pc and do a shutdown -r now
X crashed while i was using netscape: first some of the buttons above in the
window and the window that shows the webpage itself became blueish, then it

Now i'm running back in XFree86 3.3.6 (from XFree86-3DLabs-3.3.6-35)
which seems to work now

Please let me know if you want me to test something or if you need certain
kind regards,
Comment 5 Dries Verachtert 2001-04-12 18:07:26 EDT
I forgot to include this in the last comment:
I checked your webpage http://people.redhat.com/mharris/ but it was empty. Can I
download those patches somewhere else?

Kind regards,
Comment 6 Dries Verachtert 2001-04-13 09:13:02 EDT
XFree86 3.3.6 also crashed after 1 day. This time i didn't had to reboot the
machine.. i still could login from another pc and after a 'killall X' i was back
at the console.
Comment 7 Mike A. Harris 2001-04-13 10:44:11 EDT
My mistake.  It *should* have read:

Comment 8 Mike A. Harris 2001-04-13 13:55:43 EDT
I mistakenly gave a bad URL above.  ;o(  The proper URL is:


Not http.  Please try out the latest code and let me know if this problem is
fixed now.
Comment 9 Dries Verachtert 2001-04-16 05:10:47 EDT
The new version at your ftpsite seems to work fine on this machine. The previous
version almost immediately crashed when you load in some webpages in netscape
but this version seems to survive that. X is running for some 15 minutes now. If
it still didn't crash tomorrow morning, i'll close this bugreport...

Thanks for the new version :-)
Comment 10 Dries Verachtert 2001-04-18 04:39:12 EDT
This new XFree86 version works without any problems so i guess the bug is
solved.  Thank you very much for fixing the problem!

Note You need to log in before you can comment on or make changes to this bug.