This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 249773 - valgrind fails with PPC64 applications
valgrind fails with PPC64 applications
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: valgrind (Show other bugs)
7
ppc64 Linux
low Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-26 18:10 EDT by Patrick Clément-Bonhomme
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 3.2.3-5.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 12:43:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
strace log of valgrind with a PPC64 application (2.74 KB, text/plain)
2007-07-26 18:10 EDT, Patrick Clément-Bonhomme
no flags Details

  None (edit)
Description Patrick Clément-Bonhomme 2007-07-26 18:10:32 EDT
Description of problem:
valgrind fails to start its tools (memcheck, cachegrind, helgrind) when it is
used to profile applications for PPC64 (e.g. 64-bit applications). Since
valgrind relies on these tools, the bug makes it practically useless.

The following error message is reported by valgrind while running it without any
option or argument:
$ valgrind name-of-application
valgrind: failed to start tool 'memcheck' for platform 'ppc64-linux': No such
file or directory

Version-Release number of selected component (if applicable):
* valgrind.ppc64 3.2.3-2
* valgrind.ppc 3.2.3-2   

How reproducible:
Always.

Steps to Reproduce:
1. Find or compile a PPC64 application. 
2. Try to profile the application with valgrind :
   $ valgrind name-of-program
  
Actual results:
valgrind cannot find the requested tool, thus failing to profile the application.

Expected results:
valgrind and its tools should profile applications correctly.

Additional info:
* valgrind works correctly with PPC32 applications.
* If you cannot find a PPC64 application, you can use valgrind on /lib64/libc.so.6 :
  $ valgrind /lib64/libc.so.6
* It seems to be a path issue. While running valgrind with the debug switch, it
tries to access an unexisting file :
  [paclb@ps3-gel01 celldt]$ valgrind -d /tmp/celldt/convofilter
  --26657:1:debuglog DebugLog system started by Stage 1, level 1 logging requested
  --26657:1:launcher no tool requested, defaulting to 'memcheck'
  --26657:1:launcher selected platform 'ppc64-linux'
  --26657:1:launcher launching /usr/lib/valgrind/ppc64-linux/memcheck
valgrind: failed to start tool 'memcheck' for platform 'ppc64-linux': No such
file or directory

  The directory /usr/lib/valgrind/ppc64-linux doesn't exist, but
/usr/lib64/valgrind/ppc64-linux does (and contains the requested tools).
* I have included an strace of the previous command.
Comment 1 Patrick Clément-Bonhomme 2007-07-26 18:10:32 EDT
Created attachment 160082 [details]
strace log of valgrind with a PPC64 application
Comment 2 Patrick Clément-Bonhomme 2007-07-26 18:22:11 EDT
Just confirming that it is a path issue, since making the following symbolic
link does the job :
# ln -s /usr/lib64/valgrind/ppc64-linux /usr/lib/valgrind/ppc64-linux
Comment 3 Fedora Update System 2007-09-04 18:02:17 EDT
valgrind-3.2.3-5.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2007-09-12 12:43:20 EDT
valgrind-3.2.3-5.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.