Bug 249792 - the option '--usage' does not exist, should be deleted from the manpage
Summary: the option '--usage' does not exist, should be deleted from the manpage
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: logwatch   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-27 01:13 UTC by Yu Zhiguo
Modified: 2008-05-21 15:59 UTC (History)
0 users

Fixed In Version: RHBA-2008-0303
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 15:59:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the patch to the logwatch manpage (726 bytes, patch)
2007-07-27 01:13 UTC, Yu Zhiguo
no flags Details | Diff
add option "--usage" for logwatch (1.46 KB, patch)
2008-01-16 01:49 UTC, Yu Zhiguo
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0303 normal SHIPPED_LIVE logwatch bug fix and enhancement update 2008-05-20 17:57:28 UTC

Description Yu Zhiguo 2007-07-27 01:13:29 UTC
Description of problem:
the option '--usage' does not exist, so the description about this nonexistent 
option should be deleted from the manpage.

Version-Release number of selected component (if applicable):
logwatch-7.3-5.noarch.rpm

How reproducible:
100%

Steps to Reproduce:
1.execute command "man logwatch"
  
Actual results:
the description about option '--usage' exists

Expected results:
the description about option '--usage' should be deleted

Additional info:

Comment 1 Yu Zhiguo 2007-07-27 01:13:29 UTC
Created attachment 160086 [details]
the patch to the logwatch manpage

Comment 2 Yu Zhiguo 2007-07-27 02:31:05 UTC
We cannot use option "--usage" to get the usage information, but option "--
help" can be used to get the usage information.
And in the code of logwatch, there are no relative codes about option "--
usage", so I think the description in the manpage should be deleted.

[root@localhost ~]# logwatch --usage
Unknown option: usage
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^


[root@localhost ~]# logwatch --help

Usage: /usr/sbin/logwatch [--detail <level>] [--logfile <name>]
   [--print] [--mailto <addr>] [--archives] [--range <range>] [--debug <level>]
   [--save <filename>] [--help] [--version] [--service <name>]
   [--numeric] [--output <output_type>]
   [--splithosts] [--multiemail]


Comment 4 RHEL Product and Program Management 2007-10-26 07:34:39 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 7 Yu Zhiguo 2008-01-16 01:47:16 UTC
I also report this bug to logwatch development maillist, the maintainer think 
option "--usage" should be added.
I created a patch for this bug, please use it.


Comment 8 Yu Zhiguo 2008-01-16 01:49:28 UTC
Created attachment 291786 [details]
add option "--usage" for logwatch

Comment 9 Yu Zhiguo 2008-01-16 01:52:35 UTC
The maintainer think option "--usage" should be added, please refer to:

> Hello Yu,
> 
> Since --usage is already documented, I added the option to logwatch 
> instead.  The new version allows --usage.
> 
> If other's disagree with this change, I'll revert and remove --usage 
> from the documentation.

Comment 12 errata-xmlrpc 2008-05-21 15:59:47 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0303.html



Note You need to log in before you can comment on or make changes to this bug.