This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 249801 - requirement of metacity?
requirement of metacity?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-27 00:17 EDT by Wei-Lun Chao
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-27 16:23:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Wei-Lun Chao 2007-07-27 00:17:38 EDT
Description of problem:
why the package system-config-display requires metacity?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. rpm -q system-config-display --requires
2.
3.
  
Actual results:
with metacity

Expected results:
without metacity

Additional info:
Comment 1 Adam Jackson 2007-07-27 16:23:19 EDT
Because it needs to run a window manager when it's invoked with no X server
running.  And metacity is the default window manager.

There's really no good way around this atm.  If there were a 'prefwm' or
something then I'd use that.  I've got gnome-wm, but that pulls in
gnome-session, which is slightly more heavyweight than metacity in terms of
requirements.  And no, not going to depend on twm instead.

Note You need to log in before you can comment on or make changes to this bug.