Bug 249813 - Kernel triggers thousands of PTWR fixups on pte_clear()
Kernel triggers thousands of PTWR fixups on pte_clear()
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel-xen (Show other bugs)
4.5
i686 Linux
low Severity low
: ---
: ---
Assigned To: Chris Lalancette
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-27 05:07 EDT by Ian Campbell
Modified: 2007-11-16 20:14 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0791
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:30:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Campbell 2007-07-27 05:07:21 EDT
pte_clear() is defined in 2.6.9-55.EL as set_pte(...,0). This clears the upper
word before the lower word which means for MFN>4G the PTE value is temporarily
invalid as far as Xen's page type tracking is concerned because the P bit is set
when the top bits are cleared:
(XEN) mm.c:649:d25 Error getting mfn 1f20e (pfn 5555555555555555) from L1 entry
000000001f20e063 for dom25
(XEN) mm.c:3295:d25 ptwr_emulate: fixing up invalid PAE PTE 000000001f20e063
(XEN) printk: 4246 messages suppressed.
etc.

The fix is to define pte_clear to clear the lower word first
http://xenbits.xensource.com/kernels/rhel4x.hg?rev/e2f1456ed7bb
Comment 1 Rik van Riel 2007-07-27 10:39:05 EDT
Thanks for pointing out these bugs, Ian.

This particular one already had a patch submitted internally on May 30th 2007, I
assume that one is already in our tree.

Chris, can this patch go into MODIFIED?
Comment 2 Chris Lalancette 2007-07-27 11:01:44 EDT
Rik,
     Yeah, this has now been committed to our internal CVS, so MODIFIED it is. 
Thanks for the bug report, Ian.

Chris Lalancette
Comment 3 RHEL Product and Program Management 2007-08-06 11:55:59 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 errata-xmlrpc 2007-11-15 11:30:53 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0791.html

Note You need to log in before you can comment on or make changes to this bug.