This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 249888 - kernel cannot detect both cores in dual-core CPU if "acpi=off" is used at boot
kernel cannot detect both cores in dual-core CPU if "acpi=off" is used at boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-27 13:46 EDT by NILMONI DEB
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-30 11:09:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description NILMONI DEB 2007-07-27 13:46:57 EDT
Description of problem:
As says in subject, the kernel detects only one of 2 cores in a dual core CPU, 
as shown by "cat /proc/cpuinfo" ->

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 14
model name      : Genuine Intel(R) CPU           T2400  @ 1.83GHz
stepping        : 8
cpu MHz         : 1830.975
cache size      : 2048 KB
physical id     : 0
siblings        : 1
core id         : 0
cpu cores       : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov 
pat clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx constant_tsc up pni 
monitor vmx est tm2 xtpr
bogomips        : 3663.67
clflush size    : 64


Version-Release number of selected component (if applicable):
kernel-2.6.22.1-33.fc7

How reproducible:
Always
Comment 1 NILMONI DEB 2007-07-27 13:50:49 EDT
Similar problems have been reported on Fedora 7 by others ->

http://forums.fedoraforum.org/showthread.php?p=822704
Comment 2 NILMONI DEB 2007-07-28 14:21:04 EDT
This problem (detecting only 1 out of 2 cores) appeared when I booted the 
kernel with "acpi=off" option (originally needed for kernel-2.6.21-1.3194.fc7 
due to bug 241249). I have verified now that this option is not needed for the 
kernel-2.6.22.1-33.fc7 to boot successfully. It seems that use of "acpi=off" 
is preventing the detection of both cores. If this option is not used then 
both cores are detected fine.
Comment 3 Chuck Ebbert 2007-07-30 11:09:55 EDT
Detection of multiple processors requires ACPI on modern machines.
Booting with kernel option "acpi=ht" might work by enabling only
enough ACPI to detect the CPUs.

Note You need to log in before you can comment on or make changes to this bug.