Bug 249902 - Ignore OnlyShowIn directive
Summary: Ignore OnlyShowIn directive
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kmenu-gnome (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Chitlesh GOORAH
QA Contact: Fedora Extras Quality Assurance
URL: https://www.redhat.com/archives/fedor...
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-27 19:22 UTC by Christopher Stone
Modified: 2009-09-21 20:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-26 23:40:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christopher Stone 2007-07-27 19:22:37 UTC
The OnlyShowIn directive should be ignored in kmenu-gnome.

See the discussion pointed to in URL field for more information.

Comment 1 Chitlesh GOORAH 2007-07-28 14:04:33 UTC
I'm closing this as a NOTABUG since on an opened gnome session, there is NO 
kmenu.

No kmenu == No kmenu-gnome


Comment 2 Christopher Stone 2007-07-28 14:52:37 UTC
What??  This is for a KDE session, not a GNOME session.  Do you not understand
the issue, or am I just confused about what this package actually does?

NOTE:  The description of this package is pretty terse, so I could be wrong, but
is not this package designed to show a GNOME menu under KDE?  I apologize if I'm
wrong, maybe this is for gnome-menus package??

Comment 3 Chitlesh GOORAH 2007-07-28 18:46:58 UTC
Yes, perhaps since I don't see OnlyShowIn in kmenu-gnome's desktop files. 

It is designed to 
* REorganize (take gnome/gtk applications under different kmenu menus and 
place them under ONE kmenu -> gnome menu)
AND 
* ADD missing gnome/gtk applications under:
kmenu -> gnome menu
see http://photos1.blogger.com/blogger2/768/1924/1600/kmenu-gnome.png

by the way what you were proposing to remove was REMOVING the MAIN feature of 
this application.

Comment 4 Christopher Stone 2007-07-30 18:02:40 UTC
I apologize for the late reply, I was away for the weekend.

The problem occurs with desktop files that are not packaged with kmenu-gnome. 
For example, banshee should show up under Gnome->Sound&Video when installed, but
it does not because it has a OnlyShowIn directive.

In addition, looking at your screenshot and comparing to what I see here.  I am
missing the Accessability, Accessories, Education, About Gnome, and Help menu
items.  I am also missing the icons[1].

[1] http://tkmame.retrogames.com/gnomemenu1.png


Comment 5 Chitlesh GOORAH 2007-07-31 00:10:54 UTC
(In reply to comment #4)
> The problem occurs with desktop files that are not packaged with 
kmenu-gnome. 
> For example, banshee should show up under Gnome->Sound&Video when installed, 
but
> it does not because it has a OnlyShowIn directive.

So this has to do with banshee.
 
> In addition, looking at your screenshot and comparing to what I see here.  I 
am
> missing the Accessability, Accessories, Education, About Gnome, and Help 
menu
> items.  I am also missing the icons[1].
> 
> [1] http://tkmame.retrogames.com/gnomemenu1.png
> 

Your icon set doesn't provide those icons.

Comment 6 Christopher Stone 2007-07-31 00:16:33 UTC
Well, if you read the discussion pointed to by the URL you will see it was
decided that it is better for kmenu-gnome to ignore OnlyShowIn, rather than fix
all the KDE/GNOME apps which inappropriately use OnlyShowIn.

Comment 7 Chitlesh GOORAH 2007-08-01 10:52:07 UTC
Ok, then this bug is a call for upstream fix, and not a packaging issue, 
right?

To be honest, I'm a bit confused with this matter.

Comment 8 Christopher Stone 2007-08-01 16:39:50 UTC
The Fedora Packaging Committee will be discussing this in more detail at the
Aug. 7th meeting.

So let's just put this on hold until we hear from the FPC on the issue.


Comment 9 Chitlesh GOORAH 2007-08-16 12:41:11 UTC
What is the status of this now ?




Comment 10 Christopher Stone 2007-08-16 13:29:30 UTC
according to the wiki page it was not discussed on the 7th and no meeting took
place last week.  I'll see if I can press this issue for discussion next Tuesday.

Comment 11 Ariszló 2007-08-19 22:05:28 UTC
kmenu-gnome does not read *.desktop files, consequently it cannot ignore
directives in them. It is just a package containing a configuration file and
some icons.

Comment 12 Chitlesh GOORAH 2007-08-19 22:22:15 UTC
Christopher, I'm introducing Ariszló (upstream) to you.

We will see what is the status of this bug after the upcoming meeting on 
tuesday.

Comment 13 Chitlesh GOORAH 2007-08-26 23:40:26 UTC
I'm closing this bug as NOTABUG.
Please do reopen this bug if a decision has been made.


Note You need to log in before you can comment on or make changes to this bug.