Bug 249998 - Liferea does not remember the configuration of the GUI
Liferea does not remember the configuration of the GUI
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-29 04:50 EDT by Thomas Canniot
Modified: 2007-12-04 10:54 EST (History)
0 users

See Also:
Fixed In Version: 1.4.8-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-04 10:54:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Canniot 2007-07-29 04:50:29 EDT
Description of problem:
Liferea used to remember the configuration of the GUI. By this, I mean it does
not remember any more how wide the side bar is, nor the preview area. But it
used to.

Version-Release number of selected component (if applicable):
Every since Fedora 7

Steps to Reproduce:
Open Liferea
Enlarge the side bar
Close Liferea and re-open it again
The side bar is back to its previous position
Comment 1 Brian Pepple 2007-07-29 09:53:48 EDT
I've tried this on several machines, and every time I start up liferea again the
sidebar is the correct size.  also, checking the gconf value for last-vpane-pos
before closing & after opening verifies this.

please provide more information, since I'm unable to reproduce this error.
Comment 2 Thomas Canniot 2007-07-29 13:34:52 EDT
I've tried on 2 machines, a desktop and a laptop. On the desktop, it works fine
and the last-vpane-pos value has got a value. On the laptop, it doesn't work and
the last-vpane-pos is fixed on 0 whatever I do. I even deleted my .liferea_1.2
without success. The size of the side bar is not saved.
Comment 3 Brian Pepple 2007-07-29 13:56:06 EDT
Let's have you try  manually changing the gconf value and see if that works. 
First off, let's close liferea.  Then use the following command to set the
feedlist sidebar width:

gconftool-2 --type integer --set /apps/liferea/last-vpane-pos 150

Then re-open liferea,and see if it is using the correct width.  If I remember
correctly, having your last-vpane-pos set to 0, uses the gtk+ hints to set the
width.  When I have some free time, I'll dig through the code and see how
they're saving the gconf settings.
Comment 4 Thomas Canniot 2007-07-30 04:36:56 EDT
Changing the gconf value manually works. But the value remains the one I set
manually. If I change the width in liferea, it is not saved and I come back to
the value set manually.
Comment 5 Thomas Canniot 2007-11-11 15:45:53 EST
That's really weird, I still have the problem on Fedora 8.
I wanted again to remove the .liferea_1.2 but Liferea doesn't mind about it and
reload my opml file even if its home folder is deleted. Are there other files
hidden somewhere ? I think I'm turning crazy...
Comment 6 Thomas Canniot 2007-11-11 16:15:18 EST
Well of course it is not my opml file but the one which is by default as an
example...
Comment 7 Brian Pepple 2007-12-01 18:24:15 EST
Thomas, are you still experiencing this bug in the 1.4.x branch?
Comment 8 Thomas Canniot 2007-12-04 03:07:00 EST
Thanks for telling as I did not even noticed there was a 1.4.x branch. I
installed it, removed the stuff in gconf and removed my liferea home folder and
it works.
Thanks, you saved my life :)
Comment 9 Brian Pepple 2007-12-04 10:54:02 EST
(In reply to comment #8)
> Thanks for telling as I did not even noticed there was a 1.4.x branch. I
> installed it, removed the stuff in gconf and removed my liferea home folder and
> it works.
> Thanks, you saved my life :)

Cool, I'll mark it as fixed in current then.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.