Bug 250044 - Democracy Player Not Working
Democracy Player Not Working
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Democracy (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Thorsten Scherf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-29 23:50 EDT by Jonathan Steffan
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: Miro-0.9.8.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 02:42:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Steffan 2007-07-29 23:50:56 EDT
Description of problem:
$ democracyplayer 
/usr/lib/python2.5/site-packages/dbus_bindings.py:1: DeprecationWarning: The
dbus_bindings module is not public API and will go away soon.

Most uses of dbus_bindings are applications catching the exception
dbus.dbus_bindings.DBusException. You should use dbus.DBusException
instead (this is compatible with all dbus-python versions since 0.40.2).

If you need additional public API, please contact the maintainers via
<dbus@lists.freedesktop.org>.

  from dbus.dbus_bindings import *
Traceback (most recent call last):
  File "/usr/bin/democracyplayer", line 89, in <module>
    onetime.OneTime()
  File "/usr/lib64/python2.5/site-packages/democracy/onetime.py", line 106, in
__init__
    dbus.service.Object.__init__(self, bus_name,
'/org/participatoryculture/dtv/OneTime')
  File "/usr/lib/python2.5/site-packages/dbus/service.py", line 424, in __init__
    self._connection._register_object_path(object_path, self._message_cb,
self._unregister_cb)
AttributeError: 'BusNameFlags' object has no attribute '_register_object_path'
Exception exceptions.NameError: "global name 'dbus_bindings' is not defined" in
<bound method BusNameFlags.__del__ of <dbus.service.BusName
org.participatoryculture.dtv.onetime on <dbus.Bus on SESSION at 0x2aaaae9c6770>
at 0x2aaab263f450>> ignored

Version-Release number of selected component (if applicable):
Democracy-0.9.5.1-8.fc7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. democracyplayer
2.
3.
  
Actual results:
Boom

Expected results:
Good Content

Additional info:
Comment 1 Andre Robatino 2007-07-30 02:05:35 EDT
  This is a duplicate of bug #244889.
Comment 2 Jonathan Steffan 2007-08-14 19:40:26 EDT
This bug may be closed. Miro fixes this issue.

Note You need to log in before you can comment on or make changes to this bug.