Bug 250062 - often pnp acpi does not find all devices
often pnp acpi does not find all devices
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-30 04:27 EDT by Sander Klous
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.22.9-91.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-12 18:30:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sander Klous 2007-07-30 04:27:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.5) Gecko/20070718 Fedora/2.0.0.5-1.fc7 Firefox/2.0.0.5

Description of problem:
About 50% to 75% of the time, pnp acpi states:
Jul 29 16:31:58 localhost kernel: pnp: PnP ACPI: found 12 devices

The rest of the times it states
Jul 29 16:40:50 localhost kernel: pnp: PnP ACPI: found 14 devices

When only 12 devices are found, my wacom serial tablet is not found, the setserial command fails and X won't start.

Hardware: Lenovo X61 tablet



Version-Release number of selected component (if applicable):
2.6.22.1-33.fc7

How reproducible:
Sometimes


Steps to Reproduce:
1. Reboot
2. Check /var/log/messages
3. Message: found N devices
4. If N=12 the problem is there, if N=14 it is not

Actual Results:
Tablet is not found, setserial and X fails

Expected Results:
Tablet should have been found and X should have started

Additional info:
Comment 1 Sander Klous 2007-07-30 04:29:17 EDT
It looks like a timeout of pnp ACPI that should be increased.
Comment 2 Christopher Brown 2007-09-21 09:23:28 EDT
Hello Sander,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris
Comment 3 Sander Klous 2007-09-24 12:56:52 EDT
(In reply to comment #2)
> Hello Sander,
> 
> I'm reviewing this bug as part of the kernel bug triage project, an attempt to
> isolate current bugs in the fedora kernel.
> 
> http://fedoraproject.org/wiki/KernelBugTriage
> 
> I am CC'ing myself to this bug and will try and assist you in resolving it if
> I can.
> 
> There hasn't been much activity on this bug for a while. Could you tell me if
> you are still having problems with the latest kernel?

I am running the latest FC7 kernel and the problem still exists.
I found out it is related to the docking station:
- If I boot from the docking station acpi finds 14 devices and all works fine.
- If I boot without docking station acpi finds 12 devices and wacom fails
Comment 4 Christopher Brown 2007-09-24 19:21:59 EDT
Thanks for the update. Could you attach the following outputs as separate
text/plain attachments:

# lspci -vvxxx (when docked)
dmesg without docking station
dmesg with docking station
lsmod after boot from docking station
lsmod after boot without docking station

I appreciate there is a lot there however this will enable me to assign the
relevant maintainer to the issue.
Comment 5 Sander Klous 2007-10-12 16:20:48 EDT
> Could you tell me if you are still having problems with the latest kernel?

This bug disappeared when I upgraded to kernel version 2.6.22.9-91.fc7.

Note You need to log in before you can comment on or make changes to this bug.