Bug 250079 - Mod_python do not fill in Range attribute
Summary: Mod_python do not fill in Range attribute
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mod_python (Show other bugs)
(Show other bugs)
Version: 4.5
Hardware: All Linux
low
low
Target Milestone: ---
: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-30 11:53 UTC by Miroslav Suchý
Modified: 2012-06-19 07:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 07:35:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Miroslav Suchý 2007-07-30 11:53:55 UTC
Description of problem:
When I make request to mod_python with Range header, it does not fill "range"
member of Request object.

Version-Release number of selected component (if applicable):
# rpm -q rhn-modpython
rhn-modpython-2.7.11-1.rhel4

How reproducible:
always
if it is our rhn snapshot of mod_python I believe it is the same in rhel version

Steps to Reproduce:
log_debug(4, "HEADERS", req.headers_in)
log_debug(4, "RANGE", req.range)

Actual results:
2007/07/30 13:42:40 +02:00 5080 10.34.32.56: common/rhnApache.handler('HEADERS',
{'X-rhn-server-id': '1007658842', 'X-rhn-auth-user-id': '',
'X-rhn-auth-server-time': '1185795660.29', 'X-rhn-auth-expire-offset': '3600.0',
'X-rhn-auth': '+LUJedU4s4zXyLj6W8uINw==', 'User-agent': 'urlgrabber/3.1.0',
'Range': 'bytes=440-12983', 'Host': 'proxy-test.englab.brq.redhat.com',
'Connection': 'close', 'Accept-Encoding': 'identity'})
2007/07/30 13:42:40 +02:00 5080 10.34.32.56: common/rhnApache.handler('RANGE', None)

Expected results:
2007/07/30 13:42:40 +02:00 5080 10.34.32.56: common/rhnApache.handler('RANGE',
'bytes=440-12983' )

Comment 1 Joe Orton 2007-07-30 19:50:56 UTC
(In reply to comment #0)
> Version-Release number of selected component (if applicable):
> # rpm -q rhn-modpython
> rhn-modpython-2.7.11-1.rhel4
> 
> How reproducible:
> always
> if it is our rhn snapshot of mod_python I believe it is the same in rhel version

RHEL 4 has mod_python 3.1.3.  There is some handling of range there.  Let me
know if you retest this against the RHEL4 mod_python and it does need fixing here.

Comment 2 Brandon Perkins 2008-07-29 20:14:42 UTC
Removing Bug 250079 blocks bug 247327.

Comment 3 Miroslav Suchý 2012-06-19 07:35:07 UTC
rhel4 is eol. and in newer rhel we use mod_wsgi.
There is not need to fix this bug anymore.


Note You need to log in before you can comment on or make changes to this bug.