Bug 250166 - glib2-devel missing dependencies
Summary: glib2-devel missing dependencies
Status: CLOSED DEFERRED
Alias: None
Product: Fedora Hosted Projects
Classification: Retired
Component: mock   
(Show other bugs)
Version: unspecified
Hardware: All Linux
urgent
high
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 249190
TreeView+ depends on / blocked
 
Reported: 2007-07-30 20:13 UTC by Christopher Stone
Modified: 2013-01-10 04:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 16:56:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christopher Stone 2007-07-30 20:13:01 UTC
Any application that uses glib2-devel is unable to build in mock due to the
following errors:
Error: Missing Dependency: libgobject-2.0.so.0 is needed by package glib2-devel
Error: Missing Dependency: libgthread-2.0.so.0 is needed by package glib2-devel
Error: Missing Dependency: libglib-2.0.so.0 is needed by package glib2-devel
Error: Missing Dependency: libgmodule-2.0.so.0 is needed by package glib2-devel


It's been like this for several days now.

Comment 1 Jesse Keating 2007-07-31 00:47:10 UTC
What repos are enabled in your mock config file?

Comment 2 Jesse Keating 2007-07-31 00:58:58 UTC
Ah, looks like a bug in mock config files.  The config file for the x86_64 repo
needs to exclude 'glib2*.i?86' rather than just 'glib2.i?86'.

Comment 3 Jos Vos 2007-08-20 17:32:54 UTC
I can confirm that this indeed solves the problem.

Comment 4 Jesse Keating 2007-11-15 16:56:41 UTC
Really we need a better way to exclude all but a couple packages, and that may
require some yum work.  I'm closing this bug for now as there is a workaround.


Note You need to log in before you can comment on or make changes to this bug.