Bug 250184 - Pirut ignores dependencies when installing or removing packages in a second try
Summary: Pirut ignores dependencies when installing or removing packages in a second try
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-30 21:53 UTC by Rahul Sundaram
Modified: 2013-03-13 05:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 18:44:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rahul Sundaram 2007-07-30 21:53:35 UTC
Description of problem:


Steps to Reproduce:
1. Select taxipilot and click apply. 
2. Pirut shows dependencies. Cancel
3. Click install again
  
Actual result:

Pirut will happily install the dependencies

Expected results:

Pirut should be consistent

Additional info:

Yum does what it needs to correctly. This is a pirut specific issue. Moreover
the problem is not just with installing packages but also removing packages.
Pirut with ignore the dependencies and remove a package or not warn the second
time when removing packages and dependencies. This can be a disaster if you try
and remove a critical package.

Comment 1 Jeremy Katz 2007-08-07 20:13:07 UTC
What versions of pirut and yum is this with? 

Comment 2 Rahul Sundaram 2007-08-07 20:37:30 UTC
pirut-1.3.7-1.fc7
yum-3.2.1-1.fc7


Comment 3 Jeremy Katz 2007-08-07 21:50:17 UTC
Can you try with the versions of pirut and yum in -updates-testing as they
should fix this 

Comment 4 Rahul Sundaram 2007-08-08 00:36:56 UTC
Nope. They haven't fixed the problem. 

Comment 5 Jeremy Katz 2007-09-12 18:44:47 UTC
I can't reproduce this any more with the current packages.  It definitely was a
problem at one point, but it seems good to me now.  If you can reproduce, please
give specific versions of yum and pirut used and make sure they're the latest ones.


Note You need to log in before you can comment on or make changes to this bug.