Bug 250184 - Pirut ignores dependencies when installing or removing packages in a second try
Pirut ignores dependencies when installing or removing packages in a second try
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-30 17:53 EDT by Rahul Sundaram
Modified: 2013-03-13 01:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 14:44:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2007-07-30 17:53:35 EDT
Description of problem:


Steps to Reproduce:
1. Select taxipilot and click apply. 
2. Pirut shows dependencies. Cancel
3. Click install again
  
Actual result:

Pirut will happily install the dependencies

Expected results:

Pirut should be consistent

Additional info:

Yum does what it needs to correctly. This is a pirut specific issue. Moreover
the problem is not just with installing packages but also removing packages.
Pirut with ignore the dependencies and remove a package or not warn the second
time when removing packages and dependencies. This can be a disaster if you try
and remove a critical package.
Comment 1 Jeremy Katz 2007-08-07 16:13:07 EDT
What versions of pirut and yum is this with? 
Comment 2 Rahul Sundaram 2007-08-07 16:37:30 EDT
pirut-1.3.7-1.fc7
yum-3.2.1-1.fc7
Comment 3 Jeremy Katz 2007-08-07 17:50:17 EDT
Can you try with the versions of pirut and yum in -updates-testing as they
should fix this 
Comment 4 Rahul Sundaram 2007-08-07 20:36:56 EDT
Nope. They haven't fixed the problem. 
Comment 5 Jeremy Katz 2007-09-12 14:44:47 EDT
I can't reproduce this any more with the current packages.  It definitely was a
problem at one point, but it seems good to me now.  If you can reproduce, please
give specific versions of yum and pirut used and make sure they're the latest ones.

Note You need to log in before you can comment on or make changes to this bug.