Bug 25020 - kmem_create: Forcing size word alignment - nfs_fh
kmem_create: Forcing size word alignment - nfs_fh
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-26 01:53 EST by Henri Schlereth
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-01 13:20:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henri Schlereth 2001-01-26 01:53:20 EST
This happens when trying to mount an NFS partition on an RH7.0 box. A cross test had a RH6.2 box
connect to the RH7.0 box successfully. The 6.2 and the 7.0 boxes could successfully mount from the
beta2 box however.

The beta2 box is an upgrade. I will test a mount from an install beta2 to the 7.0 box later today.

Here are the messages:

Jan 25 22:03:07 rock kernel: kmem_create: Forcing size word alignment - nfs_fh
Jan 25 22:04:47 rock kernel: portmap: server localhost not responding, timed out
Jan 25 22:06:27 rock kernel: portmap: server localhost not responding, timed out
Jan 25 22:06:27 rock kernel: lockd_up: makesock failed, error=-5
Jan 25 22:08:07 rock kernel: portmap: server localhost not responding, timed out
Comment 1 Bob Matthews 2001-01-29 18:01:00 EST
> kmem_create: Forcing size word alignment - nfs_fh

This is a kernel debug message and can be ignored.

> portmap: server localhost not responding, timed out

This is very odd.  Make sure that the portmapper is getting started at boot
time.  If the portmapper is dying, try starting it in verbose mode.

Are you using tcp-wrappers?  If so, make sure you have the localhost IP number
(127.0.0.1) and NOT the string "localhost" in /etc/hosts.allow.

If you still can't get it to work, please append the errors to the end of this
bug report, and give the contents of your /etc/exports file and the output of
"portmap -dv".

> lockd_up: makesock failed, error=-5

Yes, you can't start locking services without a portmapper either.
Comment 2 Henri Schlereth 2001-01-29 19:09:36 EST
You mis-understood. This is how it works.

1. RH6.2 box connects to RH7.0 box ok
2. Other RH7.0 boxen connect to RH7.0 box ok

3. beta2/upgrade doesnt connect to RH7.0 box and coughs up error message.

4. Both RH6.2 and RH7.0 boxen connect to beta2/upgrade box ok.
5. beta2/upgrade connects ok to beta2/installs. ok
6. beta2/install connects to RH7.0 box ok.

The exports file looks like this on the RH7.0 box.

/home/cave (ro,no_root_squash)

What I havent tried is
a.) beta2/upgrade connect to RH6.2 box

The only thing that bothers me that since this was an upgrade and there will be people upgrading, am I an isolated instance or
will there be general upgrade problems?
Comment 3 Bob Matthews 2001-01-30 12:16:39 EST
> beta2/upgrade doesnt connect to RH7.0 box and coughs up error message.

I guess I still don't understand your setup.  Is this correct:  You are
exporting /home/cave from a RHL 7.0 box and trying to mount this via nfs on a
beta2 upgrade box?

Which box "coughs up" the error message?  What is the text of the error message?
Comment 4 Henri Schlereth 2001-01-30 12:31:15 EST
The  RH70 box(cave) exports the /home/cave.
The Beta2/upgrade (rock) tries to import via NFS and coughs up the following message:

Jan 25 22:03:07 rock kernel: kmem_create: Forcing size word alignment - nfs_fh
 Jan 25 22:04:47 rock kernel: portmap: server localhost not responding, timed out
 Jan 25 22:06:27 rock kernel: portmap: server localhost not responding, timed out
 Jan 25 22:06:27 rock kernel: lockd_up: makesock failed, error=-5
 Jan 25 22:08:07 rock kernel: portmap: server localhost not responding, timed out

As I listed it in the beginning of this bug report.

portmap and lockd should not be an issue with the machine issuing the mount command AFAIK
I have tested a beta2/install and it successfully mounts the RH70 partition. I will try to also mount a RH6.2 partition
as well. I understand that the beta2/upgrade can be flaky but wanted to report all this just in case.
Comment 5 Henri Schlereth 2001-02-01 13:11:44 EST
You were right. Turns out I had a test security script running the was disabling
portmap et al on
the machine trying to mount the NFS  share on the RH70 box. My apologies.
Comment 6 Bob Matthews 2001-02-01 13:20:13 EST
No apologies necessary.  I hope I didn't appear curt.  We really do appreciate
all bug reports.

Glad your problem is fixed.

Note You need to log in before you can comment on or make changes to this bug.