This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 250203 - ia64 Xen NVRAM support (Hypervisor parts)
ia64 Xen NVRAM support (Hypervisor parts)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.1
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Keiichiro Tokunaga
Martin Jenner
: OtherQA
Depends On: 246006
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-30 20:59 EDT by Keiichiro Tokunaga
Modified: 2013-07-03 09:47 EDT (History)
10 users (show)

See Also:
Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 14:57:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keiichiro Tokunaga 2007-07-30 20:59:34 EDT
Description of problem:
Some chages to Hypervisor are necessary to support NVRAM on ia64.  Other parts 
(to xen tools bz#246006) were posted to virtualist and were already pulled.

To keep consistency between kernel package and xen package (header files), it 
needs to be applied to the kernel.  Please see bz#246006 for more information.
Comment 1 Keiichiro Tokunaga 2007-07-30 21:01:51 EDT
A patch for this bug was posted to rh-kernel on 24 Jul and got three ACKs.
Comment 3 Don Zickus 2007-08-03 14:03:45 EDT
according to rhkl, this patch can be deferred to 5.2
Comment 4 Fred Yang 2007-08-03 14:15:32 EDT
I may have misunstood this BZ, but according BZ#246006, the patch has been 
ported into RHEL5.1 ?

Please get this patch into RHEL5.1 which is a major feature for IA64/Xen!
Thanks,

=======

* Thu Jul 19 2007 Daniel P. Berrange <berrange@redhat.com> - 3.0.3-34.el5
- Add NVRAM support for ia64 guests (rhbz #246006)

$ brew latest-pkg dist-5E-qu-candidate xen
Build                                     Tag                   Built by
----------------------------------------  --------------------  ---------------
-
xen-3.0.3-34.el5                          dist-5E-qu-candidate  berrange



Comment 5 Jarod Wilson 2007-08-03 14:26:05 EDT
The necessary bits have been applied to the xen tools, as stated in bug 246006.
This bug is to track getting the bits that touch hypervisor code into the
kernel-xen package, but the changes don't actually do anything to the
hypervisor, the patch is purely cosmetic to make the header files match up with
what's going to be shipped in the xen package. Thus it isn't absolutely
necessary we get it in, since it doesn't make a functional difference.
Comment 9 Don Zickus 2007-08-15 15:11:38 EDT
in 2.6.18-40.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 11 John Poelstra 2007-08-24 01:21:41 EDT
A fix for this issue should have been included in the packages contained in the
most recent snapshot (partners.redhat.com) for RHEL5.1.  

Requested action: Please verify that your issue is fixed as soon as possible to
ensure that it is included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

More assistance: If you cannot access bugzilla, please reply with a message to
Issue Tracker and I will change the status for you.  If you need assistance
accessing ftp://partners.redhat.com, please contact your Partner Manager.
Comment 12 You, Yongkang 2007-08-27 02:55:21 EDT
Verified NVRAM function is workable in RHEL5.1 snapshot3. 
Comment 14 errata-xmlrpc 2007-11-07 14:57:16 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html

Note You need to log in before you can comment on or make changes to this bug.