Bug 250304 - Default timeout causes connection timeouts against busy servers
Default timeout causes connection timeouts against busy servers
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rhnlib (Show other bugs)
3.9
All Linux
high Severity high
: ---
: ---
Assigned To: Bret McMillan
Beth Nackashi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-31 13:51 EDT by Martin Poole
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:36:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Poole 2007-07-31 13:51:40 EDT
+++ This bug was initially created as a clone of Bug #250300 +++

Description of problem:

The addition of the default timeout of 30 seconds causes connection timeouts
against busy servers or those with many registered clients.

Version-Release number of selected component (if applicable):

2.1.1-7.el3

How reproducible:

Always against busy servers.

Steps to Reproduce:
1. Create secure server with 
2.
3.
  
Actual results:

# rhnreg_ks --activationkey=test-activation-key
Connection timed out on readline

Expected results:

No timeout.


Additional info:

The issue is with the DEFAULT_TIMEOUT in
/usr/lib/python2.?/site-packages/rhn/SSL.py and its use in connections.py.

Whilst a timeout of 30 seconds might not be unreasonable for the SSL connection
to take place it is not suitable for the ongoing connection. The socket timeout
should be reset to a more reasonable value once the SSL connection is in place.

Attached is a server-side cgi which just delays for a requested amount of time
and a small python script to exercise this cgi via the rhnlib code.

-- Additional comment from mpoole@redhat.com on 2007-07-31 13:43 EST --
Created an attachment (id=160345)
python test example


-- Additional comment from mpoole@redhat.com on 2007-07-31 13:45 EST --
Created an attachment (id=160346)
server-side delay routine
Comment 1 RHEL Product and Program Management 2007-10-19 14:36:00 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.