Bug 25032 - LILO *****BOOT ERROR******
LILO *****BOOT ERROR******
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: lilo (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-26 08:58 EST by batschelet
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-26 08:58:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description batschelet 2001-01-26 08:58:53 EST
I INSTALLED RH 7 OK BUT WHEN I BOOT I ONLY GET

L   (AND A BLINKING CURSER)

WHEN I USE THE BOOT DISK LILO LOADS BUT WHEN IT BEGINS TO LOAD LYNIX I GET 
AN ERROR

0 x10 ERROR
IF I TAKE THE DISK OUT I GET

0x 80 ERROR

AND I CANNOT BOOT WINDOWS HOW CAN I GET THINGS GOING NOW
PLEASE HELP
Comment 1 Doug Ledford 2001-01-31 01:05:20 EST
This is a misconfiguration of the /boot area of your linux system.  The /boot
partition on the hard drive must lie entirely within the first 1024 cylinders of
your hard drive.  If it doesn't, then linux won't be able to boot from the hard
drive.  Most likely, since you had Windows on the machine first, you didn't get
the /boot partition low enough on the hard drive for the BIOS to be able to read
it.  You *might* be able to solve this problem by switching your BIOS to use LBA
access mode for your hard drive if it isn't already using it.  That's why the
lilo prompt only came up as a L and a blinking cursor.  Note: I'm closing this
bug out and marking it as NOTABUG because this limitation of lilo has been
around since it was first written and has been documented in so many places,
including Red Hat's basic getting started guide, that it's considered common
knowledge and not a bug in lilo that it doesn't work over 1024 cylinders. 
However, I'm going to open a new bug against the installer that complains that
the installer should check your boot partition to make sure it's a valid
partition for lilo to use before proceeding with the installation.

Now, the reason Windows won't boot is also because lilo can't be loaded.  Lilo
is responsible for starting Windows in a dual boot situation.  If lilo isn't
working, then nothing will boot.

The reason the floppy disk is giving you errors when you try to boot from it is
because the floppy disk has a bad sector.  That gives you error number 0x10. 
Pulling the floppy back out then confuses things more and gives you error number
0x80.

My suggestion would be to boot from CD-ROM into rescue mode (the large message
that comes up when the CD-ROM boots tells how to do this), and then in rescue
mode you can do what's necessary to recover your system (I don't have the time
to write a recovery manual here, there already exists plenty of documentation on
how to recover your system, including a small amount in the Red Hat manuals, so
I would start looking those documents up).

Note You need to log in before you can comment on or make changes to this bug.