Bug 250356 - ksh's manpage description about subscripts size of index array is wrong
ksh's manpage description about subscripts size of index array is wrong
Status: CLOSED DUPLICATE of bug 250360
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ksh (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Smetana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-31 22:45 EDT by chuli
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-01 07:09:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the patch for ksh manpage (340 bytes, patch)
2007-07-31 22:45 EDT, chuli
no flags Details | Diff

  None (edit)
Description chuli 2007-07-31 22:45:45 EDT
Description of problem:
The description about subscripts size of index array in ksh's manpage is a bug.
It says " The value of all subscripts must be in the range of 0 through 4095."
But in fact it can reach 16777215(that is 16M-1)

Version-Release number of selected component (if applicable):
ksh-20060214-1.4

How reproducible:
100%

Steps to Reproduce:
1.man ksh
  
Actual results:
"The value of all subscripts must be in the range of 0 through 4095." will be 
outputed.

Expected results:
"The value of all subscripts must be in the range of 0 through 16777215." will 
be outputed.
Comment 1 chuli 2007-07-31 22:45:53 EDT
Created attachment 160388 [details]
the patch for ksh manpage
Comment 2 Tomas Smetana 2007-08-01 07:09:22 EDT

*** This bug has been marked as a duplicate of 250360 ***

Note You need to log in before you can comment on or make changes to this bug.