Bug 250364 - xfce-mcs-manager wakes up 2x/second for no good reason
Summary: xfce-mcs-manager wakes up 2x/second for no good reason
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce-mcs-manager (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-01 04:04 UTC by Matthew Miller
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 4.4.1-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-08 15:31:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Miller 2007-08-01 04:04:16 UTC
See the thread at: http://foo-projects.org/pipermail/xfce4-dev/2007-May/023071.html

The short summary is: xfce-mcs-manager wakes up a lot, which is annoying on
laptops and bad in general. A patch that solves this has been written and
applied in svn. It should be pretty clean to apply since upstream has backported
it to the 4.4.x branch -- and also for that reason, it's a temporary fix for
Fedora since it'll be included with the next upstream release.

In the meantime, could you pull this fix into the Fedora package?
http://svn.xfce.org/diff.php?repname=xfce4&path=%2Fxfce-mcs-manager%2Fbranches%2Fxfce_4_4%2Fxfce-mcs-manager%2Fxfce-mcs-manager.c&rev=25758&sc=0

Thanks!

Comment 1 Kevin Fenzi 2007-08-01 05:03:50 UTC
Yeah, I was hoping for a 4.4.2 release here, but it hasn't happened yet. 
I will look at pushing that fix in in the next few days. 
I have another fix or two for xfce-mcs-manager as well.

Thanks for the report.  

Comment 2 Matthew Miller 2007-08-01 15:49:43 UTC
Cool, thanks.

Comment 3 Kevin Fenzi 2007-08-02 03:53:36 UTC
ok. I have built a new version for rawhide/devel. Can you confirm it works as
you expect? 

You can get it from koji now: 
http://koji.fedoraproject.org/koji/buildinfo?buildID=12540
or it should be in the next push after the test1 freeze is over. 

If you can confirm it's working as you expect, I will push out a f7 and fc6
version. 

Comment 4 Matthew Miller 2007-08-02 17:14:03 UTC
Appears to be much better. Thanks.

Comment 5 Kevin Fenzi 2007-08-02 19:39:32 UTC
Excellent. Thanks for the testing. 

I have gone ahead and pushed out a F7 test version too. 
If that looks good, I will do fc6 after the f7 one is in updates. 

Comment 6 Fedora Update System 2007-08-03 02:40:13 UTC
xfce-mcs-manager-4.4.1-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2007-08-08 15:31:16 UTC
xfce-mcs-manager-4.4.1-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.