This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 250448 - Bad dependency in libwnck-devel-2.16.0-4.fc6 [NEEDINFO]
Bad dependency in libwnck-devel-2.16.0-4.fc6
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libwnck (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-01 13:49 EDT by Johnray Fuller
Modified: 2014-06-18 05:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:02:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
pm-rhel: needinfo? (jrfuller)


Attachments (Terms of Use)

  None (edit)
Description Johnray Fuller 2007-08-01 13:49:38 EDT
Description of problem:

libwnck-devel-2.16.0-4.fc6 requires:

libwnck = 2.16.0

Unfortunately, libwnck-2.16.0-4.fc6 does not provide "libwnck = 2.16.0", but rather:

libwnck = 2.16.0-4.fc6

This means I get the following error when updating:

yum install libwnck-devel
<snip>
Resolving Dependencies
--> Running transaction check
---> Package control-center-devel.x86_64 1:2.16.0-14.el5 set to be updated
---> Package libwnck-devel.x86_64 0:2.16.0-4.fc6 set to be updated
---> Package libwnck-devel.i386 0:2.16.0-4.fc6 set to be updated
---> Package control-center-devel.i386 1:2.16.0-14.el5 set to be updated
--> Processing Dependency: libwnck-1.so.18 for package: libwnck-devel
--> Processing Dependency: libwnck = 2.16.0-0 for package: libwnck-devel
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package libwnck-devel.x86_64 0:2.16.0-4.fc6 set to be updated
---> Package libwnck-devel.i386 0:2.16.0-4.fc6 set to be updated
---> Package libwnck.i386 0:2.16.0-4.fc6 set to be updated
--> Processing Dependency: libwnck = 2.16.0-0 for package: libwnck-devel
--> Finished Dependency Resolution
Error: Missing Dependency: libwnck = 2.16.0-0 is needed by package libwnck-devel

This is due to a spec file error:

%package devel
Summary: Libraries and headers for libwnck
Group: Development/Libraries
Requires: %name = %{version}

This should be:

%package devel
Summary: Libraries and headers for libwnck
Group: Development/Libraries
Requires: %name = %{version}-%{release}

J
Comment 1 RHEL Product and Program Management 2014-03-07 07:39:38 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-02 09:02:33 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.