Bug 250476 - yum: (more) kdesdk/kdebindings, perl(DCOP) pain
Summary: yum: (more) kdesdk/kdebindings, perl(DCOP) pain
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 247769 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-01 20:00 UTC by Rex Dieter
Modified: 2014-01-21 22:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-27 12:24:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum update -d 9 traceback (14.70 KB, text/plain)
2007-08-15 13:24 UTC, Rex Dieter
no flags Details
yum (-3.2.3-0.pre) update -d 9 traceback (5.61 KB, text/plain)
2007-08-17 18:06 UTC, Rex Dieter
no flags Details

Description Rex Dieter 2007-08-01 20:00:29 UTC
Kinda similar to bug #246078 , but I'm seeing this not on x86_64 multilib, but
on i386.

$ rpm -q yum
yum-3.2.2-1.fc7.noarch

Short story,
kdesdk Requires: perl(DCOP)

perl(DCOP) = 0.01
is provided by both
kdebindings-3.5.6
kdebindings-dcopperl-3.5.7
(it was moved into a separate pkg on update).

Problem:
yum install kdesdk
pulls in kdebindings-3.5.6
not necessarily bad/wrong (yet).

But now,
yum update
...
Resolving Dependencies
--> Running transaction check
...
---> Package kdebindings.i386 0:3.5.7-1.fc7.1 set to be updated
...
--> Processing Dependency: perl(DCOP) for package: kdesdk
--> Finished Dependency Resolution
Error: Unresolveable requirement perl(DCOP) for kdesdk

Ugh.  Would be preferred (from my pov) if yum would have found/pulled in
kdebindings-dcopperl-3.5.7 to satisfy perl(DCOP).

Any suggestions?

Comment 1 Rex Dieter 2007-08-14 16:12:53 UTC
*** Bug 247769 has been marked as a duplicate of this bug. ***

Comment 2 Rex Dieter 2007-08-14 16:19:51 UTC
I suppose renaming kdebindings-dcopperl -> perl-DCOP would take advantage of
yum's shortest-length feature to help here.


Comment 3 Rex Dieter 2007-08-15 13:19:14 UTC
OK, creepy today, yum installs without failure, albeit not exactly what I want
to happen:

$ sudo yum install kdesdk
...
Resolving Dependencies
--> Running transaction check
---> Package kdesdk.i386 0:3.5.7-7.fc7 set to be updated
--> Processing Dependency: perl(DCOP) for package: kdesdk
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package kdebindings.i386 0:3.5.6-1.fc7 set to be updated
---> Package kdesdk.i386 0:3.5.7-7.fc7 set to be updated
...

I end up with kdebindings-3.5.6 instead of the preferred kdebindings-dcopperl-3.5.7.

Comment 4 Rex Dieter 2007-08-15 13:22:31 UTC
oh duh, problem is mostly as originally described, initial install works, 'yum
update' fails, but today I get a traceback.
yum update -d 9 log attachment coming...

Comment 5 Rex Dieter 2007-08-15 13:24:03 UTC
Created attachment 161354 [details]
yum update -d 9 traceback

Comment 6 Rex Dieter 2007-08-17 18:06:59 UTC
Created attachment 161757 [details]
yum (-3.2.3-0.pre) update -d 9   traceback

Comment 7 Rex Dieter 2007-08-23 12:20:19 UTC
I can confirm Yum 3.2.3 (as announced on yum-devel list yesterday) fixes this,
for the most part.

$ yum install kdesdk
(still) installs kdesdk-3.5.7 (good) and kdebindings-3.5.6 (not preferred, oh well).

The good news is that
$ yum update
works (no crash/traceback), to upgrade/install to
kdebindings-3.5.7 + kdebindings-dcopperl-3.5.7

Comment 8 Rex Dieter 2007-08-27 12:24:22 UTC
$ rpm -q yum
yum-3.2.3-1.fc7.noarch
works too (currently in updates-testing).

good 'nuf for me, closing->errata



Note You need to log in before you can comment on or make changes to this bug.