Bug 250527 - 2.6.22.1-41.fc7 Problem stack trace from bcm43xx_mac80211 driver
2.6.22.1-41.fc7 Problem stack trace from bcm43xx_mac80211 driver
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-01 21:17 EDT by David Campbell
Modified: 2009-11-28 05:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-26 19:48:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Campbell 2007-08-01 21:17:46 EDT
Description of problem:

The below exception is seen from the bcm43xx_mac80211 driver.
The wireless networking also doesn't seem to be working.
I have managed to get the wireless networking going with a ndiswrapper driver,
but not with this native driver, or with the older bcm43xx driver for that matter.

Version-Release number of selected component (if applicable):

2.6.22.1-41.fc7

How reproducible:

This driver needs firmware that has to be installed from an external location
into /lib/firmware, so I've included detail of what I'm doing.

Steps to Reproduce:

1. yum install bcm43xx-fwcutter
2. wget http://downloads.openwrt.org/sources/broadcom-wl-4.80.53.0.tar.bz2
3. tar xjvf broadcom-wl-4.80.53.0.tar.bz2
4. bcm43xx-fwcutter -w /lib/firmware broadcom-wl-4.80.53.0/kmod/wl_apsta.o
5. modprobe bcm43xx_mac80211

Actual results:

dmesg reports the following:

ACPI: PCI Interrupt 0000:02:04.0[A] -> GSI 19 (level, low) -> IRQ 18
ssb: Core 0 found: ChipCommon (cc 0x800, rev 0x04, vendor 0x4243)
ssb: Core 1 found: IEEE 802.11 (cc 0x812, rev 0x05, vendor 0x4243)
ssb: Core 2 found: PCMCIA (cc 0x80D, rev 0x02, vendor 0x4243)
ssb: Core 3 found: V90 (cc 0x807, rev 0x02, vendor 0x4243)
ssb: Core 4 found: PCI (cc 0x804, rev 0x09, vendor 0x4243)
ssb: Switching to ChipCommon core, index 0
ssb: Switching to PCI core, index 4
ssb: Sonics Silicon Backplane found on PCI device 0000:02:04.0
bcm43xx-phy2: Broadcom 4306 WLAN found
ssb: Switching to IEEE 802.11 core, index 1
bcm43xx-phy2 debug: Found PHY: Analog 2, Type 2, Revision 2
bcm43xx-phy2 debug: Found Radio: Manuf 0x17F, Version 0x2050, Revision 2
bcm43xx-phy2 debug: Radio turned off
wmaster0: Selected rate control algorithm 'simple'
bcm43xx-phy2 debug: Adding Interface type 2
ssb: Switching to PCI core, index 4
ssb: Switching to IEEE 802.11 core, index 1
bcm43xx-phy2 debug: Loading firmware version 351.126 (2006-07-29 05:54:02)
ssb: Switching to ChipCommon core, index 0
ssb: Switching to IEEE 802.11 core, index 1
bcm43xx-phy2 debug: Radio turned on
bcm43xx-phy2 debug: Radio enabled by hardware
bcm43xx-phy2 debug: bbatt(11) >= size of LO array
 [<f8e30ebe>] bcm43xx_get_lo_g_ctl+0x63/0xa1 [bcm43xx_mac80211]
 [<f8e30f2e>] bcm43xx_lo_g_ctl_current+0x32/0x35 [bcm43xx_mac80211]
 [<f8e31014>] bcm43xx_lo_g_adjust+0x8/0x12 [bcm43xx_mac80211]
 [<f8e2ba5b>] bcm43xx_phy_init_pctl+0x2ed/0x603 [bcm43xx_mac80211]
 [<f8e2653b>] bcm43xx_phy_write+0x5f/0x67 [bcm43xx_mac80211]
 [<f8e2eadb>] bcm43xx_phy_initg+0xbdd/0xc3f [bcm43xx_mac80211]
 [<c042eb6a>] msleep+0xd/0x12
 [<f8e2f268>] bcm43xx_phy_init+0x518/0x53c [bcm43xx_mac80211]
 [<f8e239e4>] bcm43xx_chip_init+0x64f/0x92e [bcm43xx_mac80211]
 [<f8e23edd>] bcm43xx_wireless_core_init+0x21a/0x6a0 [bcm43xx_mac80211]
 [<f8e24eb9>] bcm43xx_add_interface+0x5a/0xe5 [bcm43xx_mac80211]
 [<c04217d9>] __wake_up+0x32/0x43
 [<f8e010e2>] ieee80211_open+0x1fe/0x306 [mac80211]
 [<c05bd1a5>] netlink_insert+0x106/0x110
 [<c05ab5e5>] dev_open+0x2e/0x68
 [<c05aa0b7>] dev_change_flags+0x4c/0xfa
 [<c05e799a>] devinet_ioctl+0x250/0x56e
 [<c04ec538>] copy_to_user+0x34/0x48
 [<c05a085b>] sock_ioctl+0x19f/0x1be
 [<c05a06bc>] sock_ioctl+0x0/0x1be
 [<c0483381>] do_ioctl+0x21/0xa0
 [<c0452af7>] audit_syscall_exit+0x2f2/0x30e
 [<c0483637>] vfs_ioctl+0x237/0x249
 [<c0483695>] sys_ioctl+0x4c/0x67
 [<c0404f8e>] syscall_call+0x7/0xb
 =======================
bcm43xx-phy2 debug: Chip initialized
bcm43xx-phy2 debug: 30-bit DMA initialized
bcm43xx-phy2 debug: Wireless interface started
ADDRCONF(NETDEV_UP): wlan0: link is not ready
bridge-wlan0: enabling the bridge
bridge-wlan0: up



Expected results:

I would have expected no exception, and for the driver to work.

Additional info:
Comment 1 Kaare Fiedler Christiansen 2007-08-03 09:19:45 EDT
The stack trace is a duplicate of bug #249483. Note that the stack trace is not
the reason for your wireless driver not working, however I can't say what is
wrong. For me the driver has worked since 2.6.22.1-33.fc7.
Comment 2 John W. Linville 2007-08-03 09:55:01 EDT
Are you trying to bridge the wireless device?  I doubt if that will work.  
Could you remove the briding configuration and try again?
Comment 3 David Campbell 2007-08-03 19:52:42 EDT
When you say bridge, do you mean bridging two ethernet connections, or something
else?  It isn't something I set up as far as I know.  Please tell me what to change.

/etc/sysconfig/network-scripts/ifcfg-wlan0 says:

TYPE=Wireless
DEVICE=wlan0
BOOTPROTO=none
HWADDR=00:0C:76:CA:71:33
ONBOOT=yes
MODE=Managed
Comment 4 John W. Linville 2007-08-30 18:02:52 EDT
Please try the latest available F7 kernel.  Does the problem persist?
Comment 5 David Campbell 2007-08-30 21:14:38 EDT
I can confirm that the stack trace no longer happens in the 2.6.22.4-65.fc7
kernel, but the error still does "b43-phy0 ERROR: bbatt(11) >= size of LO
array".  Also the drive usually doesn't connect, even 1 metre from the wireless
router.  I have managed to get it to connect on occasions...details below...

b43-phy0: Broadcom 4306 WLAN found
b43-phy0 debug: Found PHY: Analog 2, Type 2, Revision 2
b43-phy0 debug: Found Radio: Manuf 0x17F, Version 0x2050, Revision 2
b43-phy0 debug: Radio turned off
wmaster0: Selected rate control algorithm 'simple'
b43-phy0 debug: Adding Interface type 2
b43-phy0 debug: Loading firmware version 351.126 (2006-07-29 05:54:02)
b43-phy0 debug: Radio turned on
b43-phy0 debug: Radio enabled by hardware
b43-phy0 ERROR: bbatt(11) >= size of LO array
b43-phy0 debug: Chip initialized
b43-phy0 debug: 30-bit DMA initialized
b43-phy0 debug: Wireless interface started
ADDRCONF(NETDEV_UP): wlan0: link is not ready
bridge-wlan0: enabling the bridge
bridge-wlan0: up
ata2.00: configured for UDMA/100
ata2: EH complete

I have actually had wireless networking working with the bcm43xx_mac80211 driver
for the first time now, but getting it to connect is very flakey, even one metre
from the antenna, but once I manage to convince it to connect (when I've stopped
NetworkManager and rmmod'd the driver modules and then issued a modprobe
bcm43xx_mac80211 command and then restarted the NetworkManager), then it seems
stable.

On the odd occasion when the driver has actually connected I get this:

b43-phy0 debug: Using hardware based encryption for keyidx: 0, mac: ff:ff:ff:ff:
ff:ff
wlan0: Initial auth_alg=1
wlan0: authenticate with AP 00:11:09:bf:b8:45
wlan0: RX authentication from 00:11:09:bf:b8:45 (alg=1 transaction=2 status=0)
wlan0: replying to auth challenge
wlan0: RX authentication from 00:11:09:bf:b8:45 (alg=1 transaction=4 status=0)
wlan0: authenticated
wlan0: associate with AP 00:11:09:bf:b8:45
wlan0: RX AssocResp from 00:11:09:bf:b8:45 (capab=0x431 status=0 aid=2)
wlan0: failed to parse AssocResp
wlan0: associate with AP 00:11:09:bf:b8:45
wlan0: RX AssocResp from 00:11:09:bf:b8:45 (capab=0x431 status=0 aid=2)
wlan0: failed to parse AssocResp
wlan0: associate with AP 00:11:09:bf:b8:45
wlan0: RX AssocResp from 00:11:09:bf:b8:45 (capab=0x431 status=0 aid=2)
wlan0: associated
wlan0: CTS protection enabled (BSSID=00:11:09:bf:b8:45)
wlan0: switched to short barker preamble (BSSID=00:11:09:bf:b8:45)
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: no IPv6 routers present

Here's what I get when it fails:

b43-phy0 debug: Using hardware based encryption for keyidx: 0, mac:
ff:ff:ff:ff:ff:ff
wlan0: Initial auth_alg=1
wlan0: authenticate with AP 00:11:09:bf:b8:45
wlan0: RX authentication from 00:11:09:bf:b8:45 (alg=1 transaction=2 status=0)
wlan0: replying to auth challenge
wlan0: RX authentication from 00:11:09:bf:b8:45 (alg=1 transaction=4 status=0)
wlan0: authenticated
wlan0: associate with AP 00:11:09:bf:b8:45
wlan0: RX AssocResp from 00:11:09:bf:b8:45 (capab=0x431 status=0 aid=2)
wlan0: failed to parse AssocResp
wlan0: associate with AP 00:11:09:bf:b8:45
wlan0: RX AssocResp from 00:11:09:bf:b8:45 (capab=0x431 status=0 aid=2)
wlan0: failed to parse AssocResp
wlan0: associate with AP 00:11:09:bf:b8:45
wlan0: RX AssocResp from 00:11:09:bf:b8:45 (capab=0x431 status=0 aid=2)
wlan0: failed to parse AssocResp
wlan0: association with AP 00:11:09:bf:b8:45 timed out
b43-phy0 debug: Using software based encryption for keyidx: 0, mac:
ff:ff:ff:ff:ff:ff
qwlan0: privacy configuration mismatch and mixed-cell disabled - disassociate
b43-phy0 debug: Using hardware based encryption for keyidx: 0, mac:
ff:ff:ff:ff:ff:ff
wlan0: Initial auth_alg=1
wlan0: authenticate with AP 00:11:09:bf:b8:45
wlan0: RX authentication from 00:11:09:bf:b8:45 (alg=1 transaction=2 status=0)
wlan0: replying to auth challenge
wlan0: RX authentication from 00:11:09:bf:b8:45 (alg=1 transaction=4 status=0)
wlan0: authenticated
wlan0: associate with AP 00:11:09:bf:b8:45
wlan0: RX AssocResp from 00:11:09:bf:b8:45 (capab=0x431 status=0 aid=2)
wlan0: failed to parse AssocResp
wlan0: associate with AP 00:11:09:bf:b8:45
wlan0: RX AssocResp from 00:11:09:bf:b8:45 (capab=0x431 status=0 aid=2)
wlan0: failed to parse AssocResp
wlan0: associate with AP 00:11:09:bf:b8:45
wlan0: RX AssocResp from 00:11:09:bf:b8:45 (capab=0x431 status=0 aid=2)
wlan0: failed to parse AssocResp
wlan0: association with AP 00:11:09:bf:b8:45 timed out
b43-phy0 debug: Using software based encryption for keyidx: 0, mac:
ff:ff:ff:ff:ff:ff
b43-phy0 debug: Removing Interface type 2
b43-phy0 debug: Wireless interface stopped
b43-phy0 debug: DMA-32 0x0200 (RX) max used slots: 1/64
b43-phy0 debug: DMA-32 0x02A0 (TX) max used slots: 0/128
b43-phy0 debug: DMA-32 0x0280 (TX) max used slots: 0/128
b43-phy0 debug: DMA-32 0x0260 (TX) max used slots: 0/128
b43-phy0 debug: DMA-32 0x0240 (TX) max used slots: 0/128
b43-phy0 debug: DMA-32 0x0220 (TX) max used slots: 4/128
b43-phy0 debug: DMA-32 0x0200 (TX) max used slots: 0/128
b43-phy0 debug: Radio turned off
b43-phy0 debug: Radio turned off
bridge-wlan0: disabling the bridge
bridge-wlan0: down
b43-phy0 debug: Adding Interface type 2
b43-phy0 debug: Loading firmware version 351.126 (2006-07-29 05:54:02)
b43-phy0 debug: Radio turned on
b43-phy0 debug: Radio enabled by hardware
b43-phy0 debug: Chip initialized
b43-phy0 debug: 30-bit DMA initialized
b43-phy0 debug: Wireless interface started
ADDRCONF(NETDEV_UP): wlan0: link is not ready
bridge-wlan0: enabling the bridge
bridge-wlan0: up
b43-phy0 debug: Using hardware based encryption for keyidx: 0, mac:
ff:ff:ff:ff:ff:ff
wlan0: Initial auth_alg=1
wlan0: authenticate with AP 00:11:09:bf:b8:45
wlan0: RX authentication from 00:11:09:bf:b8:45 (alg=1 transaction=2 status=0)
wlan0: replying to auth challenge
wlan0: RX authentication from 00:11:09:bf:b8:45 (alg=1 transaction=4 status=0)
wlan0: authenticated
wlan0: associate with AP 00:11:09:bf:b8:45
wlan0: RX AssocResp from 00:11:09:bf:b8:45 (capab=0x431 status=0 aid=2)
wlan0: failed to parse AssocResp
wlan0: associate with AP 00:11:09:bf:b8:45
wlan0: RX AssocResp from 00:11:09:bf:b8:45 (capab=0x431 status=0 aid=2)
wlan0: failed to parse AssocResp
wlan0: associate with AP 00:11:09:bf:b8:45
wlan0: RX AssocResp from 00:11:09:bf:b8:45 (capab=0x431 status=0 aid=2)
wlan0: failed to parse AssocResp
wlan0: association with AP 00:11:09:bf:b8:45 timed out
b43-phy0 debug: Using software based encryption for keyidx: 0, mac:
ff:ff:ff:ff:ff:ff
wlan0: privacy configuration mismatch and mixed-cell disabled - disassociate
b43-phy0 debug: Using hardware based encryption for keyidx: 0, mac:
ff:ff:ff:ff:ff:ff
wlan0: Initial auth_alg=1
wlan0: authenticate with AP 00:11:09:bf:b8:45
wlan0: RX authentication from 00:11:09:bf:b8:45 (alg=1 transaction=2 status=0)
wlan0: replying to auth challenge
wlan0: RX authentication from 00:11:09:bf:b8:45 (alg=1 transaction=4 status=0)
wlan0: authenticated
wlan0: associate with AP 00:11:09:bf:b8:45
wlan0: RX AssocResp from 00:11:09:bf:b8:45 (capab=0x431 status=0 aid=2)
wlan0: failed to parse AssocResp
wlan0: associate with AP 00:11:09:bf:b8:45
wlan0: RX AssocResp from 00:11:09:bf:b8:45 (capab=0x431 status=0 aid=2)
wlan0: failed to parse AssocResp
wlan0: associate with AP 00:11:09:bf:b8:45
wlan0: RX AssocResp from 00:11:09:bf:b8:45 (capab=0x431 status=0 aid=2)
wlan0: failed to parse AssocResp
wlan0: association with AP 00:11:09:bf:b8:45 timed out
b43-phy0 debug: Using software based encryption for keyidx: 0, mac:
ff:ff:ff:ff:ff:ff
b43-phy0 debug: Removing Interface type 2
b43-phy0 debug: Wireless interface stopped
b43-phy0 debug: DMA-32 0x0200 (RX) max used slots: 1/64
b43-phy0 debug: DMA-32 0x02A0 (TX) max used slots: 0/128
b43-phy0 debug: DMA-32 0x0280 (TX) max used slots: 0/128
b43-phy0 debug: DMA-32 0x0260 (TX) max used slots: 0/128
b43-phy0 debug: DMA-32 0x0240 (TX) max used slots: 0/128
b43-phy0 debug: DMA-32 0x0220 (TX) max used slots: 4/128
b43-phy0 debug: DMA-32 0x0200 (TX) max used slots: 0/128
b43-phy0 debug: Radio turned off
b43-phy0 debug: Radio turned off
bridge-wlan0: disabling the bridge
bridge-wlan0: down
b43-phy0 debug: Adding Interface type 2
b43-phy0 debug: Loading firmware version 351.126 (2006-07-29 05:54:02)
b43-phy0 debug: Radio turned on
b43-phy0 debug: Radio enabled by hardware
b43-phy0 debug: Chip initialized
b43-phy0 debug: 30-bit DMA initialized
b43-phy0 debug: Wireless interface started
ADDRCONF(NETDEV_UP): wlan0: link is not ready
bridge-wlan0: enabling the bridge
bridge-wlan0: up

Comment 6 David Campbell 2007-09-26 19:48:32 EDT
I no longer see this issue in later f7 kernel releases

Note You need to log in before you can comment on or make changes to this bug.