Bug 250604 - spamassassin needs perl(ExtUtils::MakeMaker)
Summary: spamassassin needs perl(ExtUtils::MakeMaker)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-02 13:21 UTC by Maxime Carron
Modified: 2014-01-21 22:59 UTC (History)
4 users (show)

Fixed In Version: yum-3.2.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 05:05:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Maxime Carron 2007-08-02 13:21:08 UTC
Description of problem:
Missing a dependency for spamassassin

Version-Release number of selected component (if applicable):
spamassassin-3.2.2-1.fc7

How reproducible:
run yum update

Actual results:
yum error : 
---> Package spamassassin.i386 0:3.2.2-1.fc7 set to be updated
ERROR with rpm_check_debug vs depsolve:
Package spamassassin needs perl(ExtUtils::MakeMaker), this is not available.


This error already occurs when spamassassin was in testing.


Additional info:

Comment 1 Warren Togami 2007-08-02 15:47:39 UTC
repoquery --whatprovides 'perl(ExtUtils::MakeMaker)'
perl-ExtUtils-MakeMaker-0:6.30-18.fc7.x86_64

This should be available anywhere.  Is something wrong with your yum config?


Comment 2 Maxime Carron 2007-08-02 16:27:37 UTC
Actually, it's probably a bug for yum.

"yum update" doesn't dl the dependency,
but "yum install spamassassin" installs perl-ExtUtils-MakeMaker.

What do you think about that?

Comment 3 Seth Vidal 2007-08-02 18:15:52 UTC
When I have the next 3.2.3 release ready I'll note it here to see if it fixes it.



Comment 4 Dennis Jacobfeuerborn 2007-08-03 22:05:07 UTC
I'm seeing the same thing with the package system-config-date which claims that
the package ntp isn't available even though it is.

This looks more like a rpm issue though since I also get this when I take yum
out of the picture:

[root@nexus ~]# rpm -Uvh
/var/cache/yum/development/packages/system-config-date-1.9.3-2.fc8.noarch.rpm 
error: Failed dependencies:
        ntp is needed by system-config-date-1.9.3-2.fc8.noarch


Comment 5 Mamoru TASAKA 2007-08-06 10:54:56 UTC
The issue I met is perhaps related to this.

https://www.redhat.com/archives/fedora-devel-list/2007-August/msg00277.html

Comment 6 Panu Matilainen 2007-08-06 11:01:56 UTC
> This looks more like a rpm issue though since I also get this when I take yum
> out of the picture:
>
> [root@nexus ~]# rpm -Uvh
> /var/cache/yum/development/packages/system-config-date-1.9.3-2.fc8.noarch.rpm 
> error: Failed dependencies:
>        ntp is needed by system-config-date-1.9.3-2.fc8.noarch

Well, what does "rpm -q ntp" say? Rpm doesn't know about "available" packages,
only what's installed on the system...

Comment 7 Dennis Jacobfeuerborn 2007-08-06 17:36:35 UTC
(In reply to comment #6)
> > This looks more like a rpm issue though since I also get this when I take yum
> > out of the picture:
> >
> > [root@nexus ~]# rpm -Uvh
> > /var/cache/yum/development/packages/system-config-date-1.9.3-2.fc8.noarch.rpm 
> > error: Failed dependencies:
> >        ntp is needed by system-config-date-1.9.3-2.fc8.noarch
> 
> Well, what does "rpm -q ntp" say? Rpm doesn't know about "available" packages,
> only what's installed on the system...

[root@nexus ~]# rpm -q ntp
package ntp is not installed
[root@nexus ~]# rpm -qi ntp
package ntp is not installed
[root@nexus ~]# rpm -q ntp-4.2.4p2-3.fc8
ntp-4.2.4p2-3.fc8
[root@nexus ~]# rpm -qi ntp-4.2.4p2-3.fc8
Name        : ntp                          Relocations: (not relocatable)
Version     : 4.2.4p2                           Vendor: Fedora Project
Release     : 3.fc8                         Build Date: Wed 25 Jul 2007 08:49:28
PM CEST
...


Comment 8 Panu Matilainen 2007-08-08 04:53:52 UTC
Whoa... sounds like rpmdb is well and truly hosed. 
Dennis, please tar up /var/lib/rpm/ contents, do 
# rm -f /var/lib/rpm/__*
# rpm --rebuilddb

..and see if that gets any sanity into it. If not, I'd like to have a look at
the db tarball. Mind you I don't think this issue has anything to do with the
original one of yum not seeing perl(ExtUtils::MakeMaker).

Comment 9 Seth Vidal 2007-08-08 06:09:26 UTC
Comment #8: yah - I think the perl(ExtUtils::MakeMaker) and the rpmdb screwage
above are two different bugs.




Comment 10 Panu Matilainen 2007-09-11 08:31:34 UTC
Dennis, are you still experiencing the problem in comment #7? Just thinking that
it's probably some sort of temporary mishap, otherwise we'd have similar
bugreports by the dozens...

Comment 11 Dennis Jacobfeuerborn 2007-09-11 17:55:18 UTC
Sorry for not responding earlier. Rebuilding the db has fixed things for me so I
don't experience the problem any longer. 

Comment 12 Panu Matilainen 2007-09-12 05:03:51 UTC
Ok, sounds like an isolated incidence then.

Moving back to yum for the original perl(ExtUtils::MakeMaker) issue, already
fixed I guess but Seth knows better...

Comment 13 Seth Vidal 2007-09-12 05:05:49 UTC
the perl(ExtUtils::MakeMaker) issue is, I believe, resolved in 3.2.4-3 and 3.2.5.

closing as currentrelease pointing to 3.2.5


Note You need to log in before you can comment on or make changes to this bug.