Bug 250610 - No sound on a 24 in iMac (Realtek ALC885_MACPRO)
No sound on a 24 in iMac (Realtek ALC885_MACPRO)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-02 10:15 EDT by Andreas Tunek
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-13 04:58:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Tunek 2007-08-02 10:15:56 EDT
Description of problem:
There is no sound from the speakers or the line out when you run F7 on a 24 inch
iMac.

Version-Release number of selected component (if applicable):
[root@localhost tuna]# yum list alsa*
Loading "installonlyn" plugin
Installed Packages
alsa-lib.i386                            1.0.14-1.fc7           installed       
alsa-utils.i386                          1.0.14-1.fc7           installed   
[root@localhost tuna]# yum list kernel
Loading "installonlyn" plugin
Installed Packages
kernel.i686                              2.6.22.1-41.fc7        installed       

How reproducible:
Always.

Additional info:
This was supposed to be fixed in 1.0.14 (se bug 244104,
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=244104), but was not.

There is a thread in Ubuntuforums with a patch (here is the relevant post:
http://ubuntuforums.org/showthread.php?t=418681&page=5 )
Comment 1 Andreas Tunek 2007-08-11 15:30:28 EDT
Tested with the F8t1 live CD as well, no sound there either.
Comment 2 Martin Stransky 2007-08-13 04:58:19 EDT
Yeah. So you need to patch 1.0.14 drivers (by udiff-patch_realtek.txt). 

Please report that to upstream (www.alsa-project.org, just open a bug there) and
they should do that. We use alsa-drivers from stock (vanila) kernel. We don't
patch ALSA in our kernel for Fedora. 

So if you want this support in fedora, please push it through alsa project. Thanks.
Comment 3 Andreas Tunek 2007-08-14 12:24:48 EDT
Actually, I made a mistake and it seems that the version of ALSA in F8t1
actually is patched. I couldn't hear anything because the default volume is to
low. Raising the volume you can hear things clearly though. So bug closed!

Note You need to log in before you can comment on or make changes to this bug.