Bug 250632 - chmlib fix for alpha
Summary: chmlib fix for alpha
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: chmlib (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: alpha Linux
low
low
Target Milestone: ---
Assignee: Peter Lemenkov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-02 16:15 UTC by Oliver Falk
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: 0.39-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-09 16:50:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add alpha support (540 bytes, patch)
2007-08-02 16:15 UTC, Oliver Falk
no flags Details | Diff
Specfile patch to include axp patch, update release and add cl entry (1.15 KB, patch)
2007-08-02 16:16 UTC, Oliver Falk
no flags Details | Diff

Description Oliver Falk 2007-08-02 16:15:28 UTC
Attached you'll find a patch - will submit spec patch also.

Comment 1 Oliver Falk 2007-08-02 16:15:29 UTC
Created attachment 160531 [details]
Patch to add alpha support

Comment 2 Oliver Falk 2007-08-02 16:16:46 UTC
Created attachment 160532 [details]
Specfile patch to include axp patch, update release and add cl entry

Comment 3 Peter Lemenkov 2007-08-04 19:13:56 UTC
Done, thanks.
Btw, looks like we need more generic fix for multi-arch, for example, adding
something looking as follows:

#include <stdint.h>
typedef uint8_t UChar;
typedef int16_t Int16;
typedef uint16_t UInt16;
typedef int32_t Int32;
typedef uint32_t UInt32;
typedef int64_t Int64;
typedef uint64_t UInt64;

or there will be more BR for mips, arm etc )

Comment 4 Patrice Dumas 2007-08-04 22:17:45 UTC
Indeed this kind of patch would be much better.

Comment 5 Oliver Falk 2007-08-06 07:30:02 UTC
Sure, sure. Would be better! Upstream should be happy if you submit it to 'em.

Comment 6 Peter Lemenkov 2007-08-06 07:57:33 UTC
I can't test whether windoz has <stdint.h> with proper defines - please check
for stdint.h and sys/types.h on that platform.

Comment 7 Oliver Falk 2007-08-06 08:01:28 UTC
i can't tell for windoz...

Comment 8 Fedora Update System 2007-08-06 17:53:40 UTC
chmlib-0.39-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Oliver Falk 2007-08-07 13:56:12 UTC
Works as expected. Thx!

Comment 10 Fedora Update System 2007-08-09 16:50:29 UTC
chmlib-0.39-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.