Bug 250654 - error while loading shared libraries: libperl.so
Summary: error while loading shared libraries: libperl.so
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: logwatch   
(Show other bugs)
Version: 7
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-02 18:36 UTC by Greg Douglas
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-05 16:26:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Greg Douglas 2007-08-02 18:36:46 UTC
Description of problem:

After upgrading from Fedora Core 6, Logwatch no longer works. I am getting the
followng message in my mailbox from the Cron Daemon:

/etc/cron.daily/0logwatch:

/usr/bin/perl: error while loading shared libraries: libperl.so: cannot open
shared object file: No such file or directory


Version-Release number of selected component (if applicable): logwatch-7.3.4-6.fc7



How reproducible: Every time it runs (daily)


Steps to Reproduce:
1. It is scheduled to send mail to root daily.
2. I open the mail message, and get the text above.
3. I have tried to yum remove, then reistall, but same problem
  
Actual results:
Please see above

Expected results:
It worked fine in FC6

Additional info:

Comment 1 Greg Douglas 2007-08-05 16:26:38 UTC
I've determine that the problem is related to bug#250885, where yum did not
include the dependency perl-libs during the update to perl.

I have manually added the missing perl package, and it works fine now.

This bug can be closed


Note You need to log in before you can comment on or make changes to this bug.