Bug 250672 - yum-allowdowngrade doesn't seem to work
yum-allowdowngrade doesn't seem to work
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-02 16:13 EDT by Bryan Mason
Modified: 2008-03-14 17:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-14 17:03:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Mason 2007-08-02 16:13:21 EDT
Description of problem:
The yum-allowdowngrade plugin doesn't allow downgrading a package

Version-Release number of selected component (if applicable):
yum-allowdowngrade-1.1.5-1

How reproducible:
Every time.

Steps to Reproduce:
# yum list minicom
Loading "installonlyn" plugin
Loading "allowdowngrade" plugin
Setting up repositories
Reading repository metadata in from local files
Installed Packages
minicom.i386                             2.2-1.fc6              installed       
Available Packages
minicom.i386                             2.1-3                  core            

# yum --allow-downgrade update minicom-2.1-3
Loading "installonlyn" plugin
Loading "allowdowngrade" plugin
Setting up Update Process
Setting up repositories
core                      100% |=========================| 1.1 kB    00:00     
updates                   100% |=========================| 1.2 kB    00:00     
freshrpms                 100% |=========================| 2.1 kB    00:00     
extras                    100% |=========================| 1.1 kB    00:00     
brew                      100% |=========================|  951 B    00:00     
Reading repository metadata in from local files
Could not find update match for minicom-2.1-3
No Packages marked for Update/Obsoletion

# yum --allow-downgrade update minicom-2.1-3.i386
Loading "installonlyn" plugin
Loading "allowdowngrade" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Could not find update match for minicom-2.1-3.i386
No Packages marked for Update/Obsoletion

Actual results:
"Could not find update match for minicom-2.1-3.i386
No Packages marked for Update/Obsoletion"

Expected results:
minicom-2.1-3 should be installed

Additional info:
This was initially tested (and failed) with yum-allowdowngrade 1.0.3-1.fc6 with
Fedora Core 6.  I downloaded yum-utils-1.1.5-1 from Fedora 7 and rebuilt for FC6
just to make sure it wasn't fixed in the latest release.
Comment 1 Panu Matilainen 2007-08-07 05:34:03 EDT
You'll need to use install instead of update, and apparently the matching is
fairly picky: you can't specify epoch or arch. The following ought to work
though (at least it works here on F7)

# yum --allow-downgrade install minicom-2.1-3
Comment 2 Panu Matilainen 2007-08-07 05:48:17 EDT
Hrm... "works" with some luck in some cases but certainly not in every case.
Looks like it only works if the version is different and not just release or
something. That package parsing happens within yum itself, not the plugin which
only flips a switch that makes rpm transaction permit the downgrade.
Comment 3 Seth Vidal 2008-03-14 17:03:22 EDT
okay I've tested allow-downgrade on yum 3.2.12 and yum-utils 1.1.11. it appears
to behave and work properly for:

install name-ver
install name-ver-rel
install name-ver-rel.arch

I think we've fixed it in some of the yum changes recently.

Note You need to log in before you can comment on or make changes to this bug.