Bug 250675 - IWL4965 freezes/reboots system on LifeBook E8410
IWL4965 freezes/reboots system on LifeBook E8410
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iwl4965-firmware (Show other bugs)
5.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: John W. Linville
:
Depends On:
Blocks: 252448 249688 252981
  Show dependency treegraph
 
Reported: 2007-08-02 16:30 EDT by andy prowse
Modified: 2009-07-20 15:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-20 15:04:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel panic console output (1.01 KB, text/plain)
2007-08-02 16:30 EDT, andy prowse
no flags Details

  None (edit)
Description andy prowse 2007-08-02 16:30:18 EDT
Description of problem:
Loading of the iwl4965 causes the system to hang or reboot within 30-300 seconds.

Version-Release number of selected component (if applicable):
RHEL5u1 Beta
kernel-2.6.18-36.el5.x86_64
Fujitsu Lifebook E8410

How reproducible:
100%

Steps to Reproduce:
1.INstall iwl4965-firmware-4.44.17-1.noarch.rpm
2.enable wifi
3.reboot
  
Actual results:
system hangs or resets withn 30-300 seconds

Expected results:
working wifi

Additional info:
just ask
Comment 1 andy prowse 2007-08-02 16:30:18 EDT
Created attachment 160542 [details]
kernel panic console output
Comment 2 John W. Linville 2007-08-03 11:33:34 EDT
Would you mind trying the kernels here?

   http://people.redhat.com/linville/kernels/rhel5/

These have a later version of the iwl4965 driver.  Do they work more reliably 
for you?
Comment 3 andy prowse 2007-08-06 12:41:59 EDT
I am using the latest linville kernel: kernel-2.6.18-36.el5.jwltest.41.x86_64.rpm
Latest firmware from http://intellinuxwireless.org

I changed modprobe.conf:

alias wmaster0 iwl4965 to alias wlan0 iwl4965

For 2 hours I have been pinging the router under wirless (no eth0 connection)
and have a script to ifup/ifdown wlan0 every 10 seconds.  It has been running
OK.  No WEP.  I do not know the make or router at my location

I do not know if my previous problems are due to:

1. My router at home is a speedstream DSL
2. I was using WEP at home.

I am going to get a wireless router tonight and test with WEP.
Comment 4 Geoff Gustafson 2007-08-06 13:16:07 EDT
If you do narrow this down to interaction with a particular access point, that
would be great information to submit to bughost.org and we can try to get the
upstream Intel team to find that WAP and start testing with it.

You've used other Linux wireless cards with that AP?
Comment 5 andy prowse 2007-08-06 13:20:04 EDT
(In reply to comment #4)
> If you do narrow this down to interaction with a particular access point, that
> would be great information to submit to bughost.org and we can try to get the
> upstream Intel team to find that WAP and start testing with it.
> 
> You've used other Linux wireless cards with that AP?
> 

I have used RHEL5 with an ipw3945 with WEP OK, also a Linksys WPC54 pcmcia with
ndiswrapper under RHEL 4 and 5.
Comment 6 Geoff Gustafson 2007-08-06 13:58:31 EDT
Actually, if you could please file at bughost.org in any case. That will get it
seen by Intel's upstream developers; they should really know about this issue,
especially what you see in 1.0.0 (rather than 0.0.34, to which they'll probably
say, go upgrade).

They will have better questions to ask you for more information.
Comment 7 John W. Linville 2007-08-08 13:37:06 EDT
Andy, any word on your testing w/ WEP?  Testing here for several hours of 
active file transfers on both X61 and the Santa Rosa SDV has been running w/o 
problems.
Comment 9 Larry Troan 2007-08-13 13:47:30 EDT
Andy is having problems writing to this bug. His comments.....
On Mon, 2007-08-13 at 12:40 -0400, Andy Prowse wrote:
Don/Geoff
> 
> Sorry for the delay, was away for the weekend.  I still cannot update the 
> BugID.
> 
> I have opened up bug 1435 at bughost with this text.
> 
> Here is where we stand with the Fujitsu Lifebook E8410 and the IWL4965 
> wireless.
> 
> This has been tested today:
> 
> Microsoft Vista , works.
> Ubuntu 7.10 beta 4 (Gutsy Gibbon Tribe 4),  works.
> RHEL5u1 release 070725 with kernel 2.6.18-36el5.jwlltest.41 and
> iwl firmware 4.44.17.1,  fails.
> 
> Here is what I did:
> 
> Installed RHEL5u1 Client beta 20070725
> Rebooted
> Installed kernel 2.6.18-36el5.jwlltest.41
> Installed iwl firmware 4.44.17.1
> Rebooted
> During networki initialisation:
> wmaster0 SIOCSIFFLAGS: operation not supported
> System hard hang at GDM
> Hard Reset
> System up, added alias wlan0 wmaster0 to /etc/modprobe.conf
> Removed /etc/sysconfig/network-scripts/ifcfg-wmaster0
> Issued shutdown command
> system panic during shutdown,
> panic <- die <- do_invalid_op <- do_invalid_op <- iwl_irq_tasklet [iwl4965]
> Hard Reset
> System up, added wlan0 in neat (system-config-network)
> ifup wlan0 
>   -> error on Set Bit Rate
>   -> initialisation failed
> ifup wlan0
> System hard hang again.
> 
> Regards,
> Andy
> 
Comment 10 Larry Troan 2007-08-13 14:33:41 EDT
Changing Summary to reflect Fujitsu hardware per John Linville's request.
Comment 11 Larry Troan 2007-08-13 14:34:43 EDT
Setting severity per conversation with Fujitsu-Canada (was low).
Comment 12 Don Zickus 2007-08-15 15:09:58 EDT
in 2.6.18-40.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 13 andy prowse 2007-08-15 21:58:51 EDT
Hi Guys,
Tried the new kernel, still panic's the same way
Comment 14 Geoff Gustafson 2007-08-16 10:34:54 EDT
I have a test kernel here that has the latest patches from
intellinuxwireless.org (1.0.0-1), if someone can provide it to Andy:
http://tabasco.boston.redhat.com/wifi/
Comment 15 andy prowse 2007-08-16 11:50:50 EDT
Hey Guys,

Can you make this available on a people page?  I just need the i686 kernel for
now, as that what the install is on the notebook.

Thanks,
Andy
Comment 16 Geoff Gustafson 2007-08-16 11:56:59 EDT
D'oh. I'll have to rebuild for i686 then. :)
Comment 17 Geoff Gustafson 2007-08-16 13:34:36 EDT
Okay, I've posted the i686 kernel to that same URL. I'm still dependent on
someone to post the kernel externally or give me permission to do so.
Comment 19 John W. Linville 2007-09-26 09:02:01 EDT
Can we move all new activity to bug 252981 please?

Note You need to log in before you can comment on or make changes to this bug.