Bug 250696 - Fedora 7 doesn't mount Firewire-drive.
Fedora 7 doesn't mount Firewire-drive.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-02 18:24 EDT by Henrik Johansson
Modified: 2007-11-30 17:12 EST (History)
5 users (show)

See Also:
Fixed In Version: 2.6.22.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 14:15:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henrik Johansson 2007-08-02 18:24:56 EDT
Description of problem:
One of my F7-computers (ws004), doesn't mount my Firewire-drive.
The other F7-computer (kank3), can mount the drive.
It worked on both, in FC6.

Version-Release number of selected component (if applicable):
The problem has been there from first install of F7 (20070714).
[root@ws004 ~]# uname -a
Linux ws004 2.6.22.1-41.fc7 #1 SMP Fri Jul 27 18:10:34 EDT 2007 i686 i686 i386
GNU/Linux
[root@ws004 ~]# lspci -v -s 02:0c.0
02:0c.0 FireWire (IEEE 1394): NEC Corporation IEEE 1394 [OrangeLink] Host
Controller (rev 03) (prog-if 10 [OHCI])
        Subsystem: Orange Micro Root hub
        Flags: bus master, medium devsel, latency 64, IRQ 11
        Memory at fafff000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [60] Power Management version 2

How reproducible:
Always.


Steps to Reproduce:
First alt:
1. Login.
2. Power-On the drive.
Second alt:
1. Power-On the drive.
2. Start the computer.
3. Login.

  
Actual results:
The drive aren't mounted.


Expected results:
The drive should be mounted.


Additional info:
Information from the computer that mounts the drive, 
[root@kank3 log]# uname -a
Linux kank3 2.6.21-1.3228.fc7 #1 SMP Tue Jun 12 15:37:31 EDT 2007 i686 i686 i386
GNU/Linux
[root@kank3 log]# lspci -v -s 02:04.0
02:04.0 FireWire (IEEE 1394): Texas Instruments TSB12LV26 IEEE-1394 Controller
(Link) (prog-if 10 [OHCI])
        Subsystem: Accton Technology Corporation Unknown device 1394
        Flags: bus master, medium devsel, latency 66, IRQ 19
        Memory at f8415000 (32-bit, non-prefetchable) [size=2K]
        Memory at f8410000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [44] Power Management version 1

Extracts from the messages-file:
Boot of F7:
Aug  2 21:21:56 ws004 kernel: ACPI: PCI Interrupt 0000:02:0c.0[A] -> Link [LNKC]
-> GSI 11 (level, low) -> IRQ 11
Aug  2 21:21:56 ws004 kernel: firewire_ohci: Added fw-ohci device 0000:02:0c.0,
OHCI version 1.0
Aug  2 21:21:56 ws004 kernel: pnp: Device 01:01.01 activated.
Aug  2 21:21:56 ws004 kernel: firewire_core: created new fw device fw0 (0 config
rom retries)
Aug  2 21:21:56 ws004 kernel: gameport: NS558 PnP Gameport is
pnp01:01.01/gameport0, io 0x3a0, speed 727kHz
...
Power-On of the drive:
Aug  2 21:24:09 ws004 kernel: firewire_core: phy config: card 0, new root=ffc1,
gap_count=5
Aug  2 21:24:12 ws004 kernel: firewire_ohci: swap not done yet
...
Aug  2 21:24:40 ws004 kernel: firewire_core: giving up on config rom for node id
ffc0
...
Power-Off of the drive:
Aug  2 21:24:40 ws004 kernel: firewire_core: giving up on config rom for node id
ffc0
...
Power-On of the drive again:
Aug  2 22:49:19 ws004 kernel: firewire_ohci: swap not done yet
Aug  2 22:49:22 ws004 kernel: firewire_core: created new fw device fw1 (1 config
rom retries)
Aug  2 22:49:22 ws004 kernel: firewire_ohci: swap not done yet
Aug  2 22:49:23 ws004 kernel: scsi2 : SBP-2 IEEE-1394
Aug  2 22:49:23 ws004 kernel: firewire_sbp2: logged in to sbp2 unit fw1.0 (0
retries)
Aug  2 22:49:23 ws004 kernel: firewire_sbp2:  - management_agent_address:   
0xfffff0030000
Aug  2 22:49:23 ws004 kernel: firewire_sbp2:  - command_block_agent_address:
0xfffff0100000
Aug  2 22:49:23 ws004 kernel: firewire_sbp2:  - status write address:       
0x000100000000
Aug  2 22:49:23 ws004 kernel: scsi 2:0:0:0: Direct-Access-RBC WDC WD40
0BB-00CAA0            PQ: 0 ANSI: 4
Aug  2 22:49:23 ws004 kernel: sd 2:0:0:0: [sdb] 78165360 512-byte hardware
sectors (40021 MB)
Aug  2 22:49:23 ws004 kernel: sd 2:0:0:0: [sdb] Write Protect is off
Aug  2 22:49:23 ws004 kernel: sd 2:0:0:0: [sdb] Write cache: enabled, read
cache: enabled, doesn't support DPO or FUA
Aug  2 22:49:23 ws004 kernel: sd 2:0:0:0: [sdb] 78165360 512-byte hardware
sectors (40021 MB)
Aug  2 22:49:23 ws004 kernel: sd 2:0:0:0: [sdb] Write Protect is off
Aug  2 22:49:23 ws004 kernel: sd 2:0:0:0: [sdb] Write cache: enabled, read
cache: enabled, doesn't support DPO or FUA
Aug  2 22:49:23 ws004 kernel:  sdb:<6>sd 2:0:0:0: [sdb] Result:
hostbyte=DID_BUS_BUSY driverbyte=DRIVER_OK,SUGGEST_OK
Aug  2 22:49:23 ws004 kernel: end_request: I/O error, dev sdb, sector 0
Aug  2 22:49:23 ws004 kernel: Buffer I/O error on device sdb, logical block 0
Aug  2 22:49:23 ws004 kernel: sd 2:0:0:0: [sdb] Result: hostbyte=DID_BUS_BUSY
driverbyte=DRIVER_OK,SUGGEST_OK
Aug  2 22:49:23 ws004 kernel: end_request: I/O error, dev sdb, sector 0
Aug  2 22:49:23 ws004 kernel: Buffer I/O error on device sdb, logical block 0
...
Lots of lines....
Comment 1 Stefan Richter 2007-08-21 14:41:55 EDT
What card does ws004 have, and what make and model of disk is this?

I've got an OrangeLink CardBus card which looks similar in lspci -v:
06:00.0 FireWire (IEEE 1394): NEC Corporation IEEE 1394 [OrangeLink] Host
Controller (rev 03) (prog-if 10 [OHCI])
        Subsystem: Orange Micro Unknown device 8010
        Flags: bus master, medium devsel, latency 64, IRQ 18
        Memory at 80000000 (32-bit, non-prefetchable) [size=4K]
        Memory at 80001000 (32-bit, non-prefetchable) [size=256]
        Memory at 80001100 (32-bit, non-prefetchable) [size=256]
        Capabilities: [60] Power Management version 2

It works here.  I have never seen that "swap not done yet" message.  Note,
CardBus cards generally require this patch:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=25659f7183376c6b37661da6141d5eaa21479061
This fix is available in upstream Linux 2.6.23-rc2 and 2.6.22.2.
Comment 2 Stefan Richter 2007-08-21 14:44:14 EDT
PS:  "It works here" with a vanilla kernel.  I am not a Fedora user.
Comment 3 Henrik Johansson 2007-08-23 15:52:49 EDT
The text on the Firewire-card (it has USB also):
OrangeLink+
Firewire+USB 2.0 Hi-Speed

The disk is a WD Caviar 40.0 GB (WD400).
The disk cabinet is anonymous, the card inside is marked "1394/IDE BRIDGE PCB".

The disk seems OK in Windows XP, it can see the drive but doesn't understand ext2.
The disk was usable in FC6.

Comment 4 Adam Pribyl 2007-08-25 15:47:27 EDT
I think the problem is in Fedora kernel. In 2.6.21 they used to use ieee1394, in
2.6.22 it's using new firewire stack, whith causes more troubles.
Comment 5 Stefan Richter 2007-08-26 02:33:56 EDT
Are there other significant differences between ws004 and kank3, besides the
different controllers?
Comment 6 Henrik Johansson 2007-08-27 12:59:29 EDT
ws004: Dell Optiplex GX1, CPU 600MHz, Memory 640MB
kank3: Compaq Presario 8420EA, CPU 1GHz, Memory 256MB
Comment 7 Henrik Johansson 2007-08-29 13:17:48 EDT
The automatic mounting of the Firewire-drive has started to work.
I've been running the Package Updater every or every two days, since I 
installed Fedora 7.
A lot of packages has been updated since the install and I can't list when they 
where upgraded. I can see that the kernel is upgraded, but i can't remeber the
exact day.
[root@ws004 ~]# uname -a
Linux ws004 2.6.22.4-65.fc7 #1 SMP Tue Aug 21 22:36:56 EDT 2007 i686 i686 i386
GNU/Linux

Comment 8 Christopher Brown 2007-09-17 14:15:09 EDT
Closing as per bug 245251 ...

Cheers
Chris

Note You need to log in before you can comment on or make changes to this bug.