Bug 250728 - crash running as user
Summary: crash running as user
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-03 09:19 UTC by Stas Sergeev
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-07 20:20:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (2.38 KB, text/plain)
2007-08-03 09:19 UTC, Stas Sergeev
no flags Details

Description Stas Sergeev 2007-08-03 09:19:45 UTC
Description of problem:
When I run pirut as a non-root user, it
crashes, backtrace attached.
I understand it can't install packages
without the superuser privs, but still
it can do lots of other things, and it
should not crash anyway, it could display
an error message instead.

Version-Release number of selected component (if applicable):
pirut-1.3.7-1.fc7

How reproducible:
always

Steps to Reproduce:
1. $ pirut
2. watch the crash
  
Actual results:
Backtrace

Expected results:
Either run normally and complain when it
comes to installing the package, or do not
run at all but display the meaningfull error
message at least.

Additional info:

Comment 1 Stas Sergeev 2007-08-03 09:19:46 UTC
Created attachment 160591 [details]
backtrace

Comment 2 Jeremy Katz 2007-08-07 20:20:45 UTC
Fixed for pirut 1.3.10

Comment 3 Stas Sergeev 2007-08-14 17:40:59 UTC
I am not sure...

---
Config error.
Unable to start due to a configuration error.
---

is what you call a proper error message?
Well, I get the proper error message if I
hit "Details", but the above message is
confusing. There is nothing to do with the
config here.


Note You need to log in before you can comment on or make changes to this bug.