Bug 250810 - (Stan) LVM's not mounting during upgrade install.
LVM's not mounting during upgrade install.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
i686 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-03 14:38 EDT by Need Real Name
Modified: 2008-07-14 13:06 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-09 05:25:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-08-03 14:38:47 EDT
Description of problem:

On upgrade from Enterprise 4 to Enterprise 5, LVM2 volumes were not mounting. 
Only / root partition and /boot paritition were mounting.   Install error was

"The following are directories which should instead be symbolic links, which
will cause problems with the upgrade. Please return them to their original state
as symbolic links and restart the upgrade. 

 

       /usr/tmp" 


BTW: Saw a bug report under Fedora, and I'm wondering if the issue is similar.



Version-Release number of selected component (if applicable):

ES 4 to ES 5

How reproducible:

Unsure, only one machine thus far.

Steps to Reproduce:
1.  Installed ES 4 originally as partitions

2. Migrated partitions to LVM volumes and labeled those volumes with tune2fs
   Exception did not migrate / root or /boot

3. Changed /etc/fstab to reflect file system labels.

Above actions work for normal boot
  
Actual results:

During Upgrade install received:

"The following are directories which should instead be symbolic links, which
will cause problems with the upgrade. Please return them to their original state
as symbolic links and restart the upgrade. 

 

       /usr/tmp" 


Expected results:

No errors


Additional info:


Changed screen to mingetty on F2 to verify LVM not mounting volumes.

Checked mingetty on F3 saw the following errors.

WARNING : fstab file has LABEL=TMP, but this label could not be found any file
system 

 

WARNING : fstab file has LABEL=USR, but this label could not be found any file
system 

 

The errors go on, but I think you will begin to see what I see. 


Changed /etc/fstab to reflect /dev/VG/LV devices instead of labels, and install
completed WITHOUT error.

Went back and change fstab back to original format, and machine boots normally
post install.


Of course, my point is that I should not have had to make changes to the fstab.....
Comment 1 Phil Knirsch 2007-08-07 07:37:54 EDT
Thats clearly an update problem though, reassigning to anaconda team so they can
take a look at the bug.

Read ya, Phil
Comment 2 Chris Lumens 2008-04-18 07:50:31 EDT
Can you test in Fedora if possible and let us know if this is still a problem? 
I believe it should be fixed and therefore will make it into RHEL6.
Comment 3 Need Real Name 2008-04-18 08:27:36 EDT
Hmm.  Don't currently have hardware to attempt on Fedora, although my
workstation is Fedora 7, I don't have LVM configured, and current desire/need to
disrupt all the tailoring, if you know what I mean.. :)

I personally did not have an issue with Fedora, and I would need to spend some
time and effort looking up the person who reported the similar issue in Fedora
to give you the number.

If I get a chance, I may be able to look up for you.

Comment 4 Joel Andres Granados 2008-07-09 05:25:53 EDT
In-place upgrades across major releases do not preserve all system settings,
services, and custom configurations. For this reason, Red Hat strongly
recommends that you perform a fresh installation rather than a system upgrade
between major versions.
Upgrade is to be used for minor versions.
Comment 5 Need Real Name 2008-07-14 13:06:32 EDT
Of course, I'm disappointed in the answer, and of course I already provided the
workaround/fix.

Since the decision to provide support to only the Enterprise releases of RH, the
quality and knowledge level, in my eyes, of the support I do get (from RH), has
dropped significantly.

After my workaround, the issue was some minor library issues to get a few apps
running.

Also, since the issue is still clearly a bug, I've changed the status to
WONTFIX.  Joel has made clear that RH will not support upgrades, even though
I've already established that upgrades do work.


Note You need to log in before you can comment on or make changes to this bug.