Bug 250811 - clustat report wrong information about rgmanager on a GULM cluster
clustat report wrong information about rgmanager on a GULM cluster
Status: CLOSED WONTFIX
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: magma-plugins (Show other bugs)
4
i386 Linux
low Severity low
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-03 14:40 EDT by siman hew
Modified: 2009-04-16 16:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 16:03:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description siman hew 2007-08-03 14:40:07 EDT
Description of problem:
On RHEL 4U5, clustat always report rgmanger is running after a GULM cluster is
started.
With the configuration with DLM, clustat report correctly.  

How reproducible:


Steps to Reproduce:
1. create a cluster with 3 nodes using GULM lock, set one of node is lock server
2. start the cluster on all the nodes(start ccsd, lock_gulmd only)
3. run clustat, or cluster -x, showing rgmanager is running on all started nodes
  
Actual results:

[root@node02 ~]# clustat
msg_open: No route to host
Member Status: Quorate

  Member Name                              Status
  ------ ----                              ------
  node04                                   Online, rgmanager
  node03                                   Offline
  node02                                   Online, Local, rgmanager

-----------------------------------------------------------
[root@node02 ~]# clustat -x
msg_open: No route to host
<?xml version="1.0"?>
<clustat version="4.1.1">
  <quorum quorate="1" groupmember="1"/>
  <nodes>
    <node name="node04" state="1" local="0" estranged="0" rgmanager="1"
nodeid="0xffff0000540610ac"/>
    <node name="node03" state="0" local="0" estranged="0" rgmanager="0"
nodeid="0x0000000000000000"/>
    <node name="node02" state="1" local="1" estranged="0" rgmanager="1"
nodeid="0xffff0000520610ac"/>
  </nodes>
</clustat>

Expected results:

[root@node02 ~]# clustat
Member Status: Quorate

  Member Name                              Status
  ------ ----                              ------
  node04                                   Online
  node03                                   Offline
  node02                                   Online, Local

-----------------------------------------------------------
[root@node02 ~]# clustat -x
<?xml version="1.0"?>
<clustat version="4.1.1">
  <quorum quorate="1"/>
  <nodes>
    <node name="node04" state="1" local="0" estranged="0" rgmanager="0"
nodeid="0xffff0000540610ac"/>
    <node name="node03" state="0" local="0" estranged="0" rgmanager="0"
nodeid="0x0000000000000000"/>
    <node name="node02" state="1" local="1" estranged="0" rgmanager="0"
nodeid="0xffff0000520610ac"/>
  </nodes>
</clustat>


Additional info:
Comment 1 Lon Hohberger 2007-08-13 12:03:05 EDT
This is mostly because under gulm clusters, there's no such notion as virtual
groups.  If this is to be fixed, it needs to be done in the gulm magma plugin.
Comment 2 Lon Hohberger 2007-09-18 16:03:53 EDT
This would be de-stabilizing to fix in the gulm plugin.  If we can come up with
an easy way to fix this in the future, we will fix it, but for now, ->WONTFIX

Note You need to log in before you can comment on or make changes to this bug.