Bug 250821 - rarian attempts to replace scrollkeeper but does not provide "scrollkeeper"
rarian attempts to replace scrollkeeper but does not provide "scrollkeeper"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rarian (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On: 219364
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-03 15:38 EDT by Michal Jaegermann
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-10 01:10:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
results of 'yum install rarian.x86_64' command (5.46 KB, text/plain)
2007-08-03 15:38 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2007-08-03 15:38:22 EDT
Description of problem:

One can find with 'rpm -qp --provides rarian-0.5.6-3.fc8.x86_64.rpm'
librarian.so.0()(64bit)
rarian = 0.5.6-3.fc8
but 'rarian' attempts to replace 'scrollkeeper' so this results in
a spate of messages like:

ERROR with rpm_check_debug vs depsolve:
Package totem needs scrollkeeper, this is not available.
Package totem needs scrollkeeper, this is not available.
....
with predictable results.  Full output from yum attached.

To add insult to injury 'yum update' attempts to install also
a totally unneeded and unwanted 'rarian.i386' thus creating even
a bigger mess.

Version-Release number of selected component (if applicable):
rarian-0.5.6-3.fc8

How reproducible:
always
Comment 1 Michal Jaegermann 2007-08-03 15:38:23 EDT
Created attachment 160649 [details]
results of 'yum install rarian.x86_64' command
Comment 2 Matthew Barnes 2007-08-03 15:52:26 EDT
Can you try installing rarian-compat, which provides scrollkeeper?
Comment 3 Michal Jaegermann 2007-08-03 16:12:33 EDT
Yes, 'yum install rarian.x86_64 rarian-compat.x86_64' indeed works.

The problem is that the original transaction was 'yum update'.
Digging more carefully through its error output I see that that
attempted to install, scattered in various places, rarian.x86_64,
rarian.i386 and rarian-compat.x86_64 but not rarian-compat.i386.
All these were claimed to be "updates" and nothing from i386 actually
needed for anything.  That resulted in:

Error: Unresolveable requirement scrollkeeper for gucharmap
Error: Unresolveable requirement scrollkeeper >= 0.3.11 for gnome-user-docs
Error: Unresolveable requirement scrollkeeper >= 0.1.4 for gnome-media
Error: Unresolveable requirement scrollkeeper for gnumeric
Error: Unresolveable requirement scrollkeeper for gconf-editor
Error: Unresolveable requirement scrollkeeper >= 0.3.4 for gnucash-docs
Error: Unresolveable requirement scrollkeeper for gthumb
Error: Unresolveable requirement scrollkeeper for fast-user-switch-applet
Error: Unresolveable requirement scrollkeeper for ggv
Error: Unresolveable requirement scrollkeeper for gnome-utils
Error: Unresolveable requirement scrollkeeper for yelp
Error: Unresolveable requirement scrollkeeper for totem
Error: Unresolveable requirement /usr/bin/scrollkeeper-update for gtkam
Error: Unresolveable requirement scrollkeeper for gdm
Error: Unresolveable requirement scrollkeeper for gtk-doc
Error: Unresolveable requirement scrollkeeper for gnome-terminal
Error: Unresolveable requirement scrollkeeper for libgnomedb-devel
Error: Unresolveable requirement scrollkeeper for eog
Error: Unresolveable requirement scrollkeeper for rhythmbox
Error: Unresolveable requirement scrollkeeper >= 0.1.4 for printman
Error: Unresolveable requirement scrollkeeper for gnome-pilot
Error: Unresolveable requirement scrollkeeper for libgnomedb

with the last line actually terminating the whole output and
nothing obvious which would indicate what really may be the
problem.  One needs to be aware of package interdependencies
to untangle that mess (and an update from today supplying few
hundreds packages to update surely did not help).
Comment 4 Matthias Clasen 2007-08-10 01:10:17 EDT
I've now moved both the Provides and the Obsoletes to the compat package.

Note You need to log in before you can comment on or make changes to this bug.