Bug 250822 - Upgrade to 1.13.0
Upgrade to 1.13.0
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mediawiki (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On: 250819
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-03 15:43 EDT by Axel Thimm
Modified: 2008-09-16 19:27 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-16 19:27:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (616 bytes, patch)
2008-09-12 12:58 EDT, Orion Poplawski
no flags Details | Diff

  None (edit)
Description Axel Thimm 2007-08-03 15:43:40 EDT
Upgrade rawhide's (F8) mediawiki to 1.11.0 once it is release (ETA is mid August)

split off bug #250819
Comment 1 Jon Ciesla 2007-09-05 11:50:01 EDT
1.10.1 is out, FYI.  No mention of an ETA for 1.11.0, other than mid-August.
Comment 2 Bug Zapper 2008-04-04 09:32:48 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 3 Jon Ciesla 2008-04-04 09:36:21 EDT
Changed back to rawhide, Current rawhide is 1.10.4, 1.11.2 is out, as is 1.12.0.
Comment 4 Oskari Saarenmaa 2008-04-15 04:40:28 EDT
MW versions older than 1.12.0 don't work with PostgreSQL 8.3 which is included
in F9.  Is it possible to upgrade this package before F9 release?
Comment 5 Bug Zapper 2008-05-13 23:06:32 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Orion Poplawski 2008-08-13 18:37:54 EDT
Any reason I shouldn't just go ahead and do this?
Comment 7 Axel Thimm 2008-08-16 06:55:12 EDT
I've been waiting for 1.13.0 to finalize, which it just did, a new package should soon hit rawhide.
Comment 8 Axel Thimm 2008-08-16 09:43:19 EDT
The package is half-way committed, but there is a CVS server outage ATM. Will repush when the systems are back online.
Comment 9 Axel Thimm 2008-08-16 09:44:31 EDT
The package is half-way committed, but there is a CVS server outage ATM. Will repush when the systems are back online.
Comment 10 Fedora Update System 2008-09-10 03:09:34 EDT
mediawiki-1.13.0-40.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mediawiki'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7731
Comment 11 Orion Poplawski 2008-09-12 12:58:46 EDT
Created attachment 316594 [details]
patch

Axel - your 1.13.0 update wiped out a couple of fixes I had made.

One was to add the skins symlink (bug #250822)

 mkdir images
 cp -a %{buildroot}%{_datadir}/mediawiki/config .
 ln -s %{_datadir}/mediawiki/index.php index.php
+ln -s %{_datadir}/mediawiki/skins skins


The attached patch allows mediawiki to use the local instance images directory.
Comment 12 Axel Thimm 2008-09-12 14:34:21 EDT
This was not a bug, the conventional setup is to use alias for the static parts like the skins directory:

http://www.google.com/search?q=mediawiki+alias+skins

But this should possibly be better documented with an example httpd conf. There is an open bug for the (non) shipping of a *.conf file that could address this as well.
Comment 13 Orion Poplawski 2008-09-12 16:14:33 EDT
Okay.  What about the images directory issue?
Comment 14 Ismael Olea 2008-09-12 16:40:55 EDT
And the docs outside share/doc/ https://bugzilla.redhat.com/show_bug.cgi?id=459532

:-)
Comment 15 Fedora Update System 2008-09-16 19:27:51 EDT
mediawiki-1.13.0-40.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.