Bug 250823 - root_uuid error while attempting to click on a service icon
root_uuid error while attempting to click on a service icon
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Jim Parsons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-03 16:02 EDT by Corey Marthaler
Modified: 2009-04-16 18:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 12:30:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2007-08-03 16:02:12 EDT
Description of problem:
I had an active gfs/nfs service running and attempted to look at it with conga

[root@taft-04 bin]# clustat
Member Status: Quorate

  Member Name                        ID   Status
  ------ ----                        ---- ------
  taft-01                               1 Online, rgmanager
  taft-02                               2 Online, rgmanager
  taft-03                               3 Online, rgmanager
  taft-04                               4 Online, Local, rgmanager

  Service Name         Owner (Last)                   State
  ------- ----         ----- ------                   -----
  service:nfs1         taft-04                        started



------
2007-08-03T14:56:23 ERROR Zope.SiteErrorLog
https://taft-04:8084/luci/cluster/index_html
Traceback (innermost last):
  Module ZPublisher.Publish, line 115, in publish
  Module ZPublisher.mapply, line 88, in mapply
  Module ZPublisher.Publish, line 41, in call_object
  Module Shared.DC.Scripts.Bindings, line 311, in __call__
  Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec
  Module Products.PageTemplates.ZopePageTemplate, line 255, in _exec
  Module Products.PageTemplates.PageTemplate, line 104, in pt_render
   - <ZopePageTemplate at /luci/cluster/index_html>
  Module TAL.TALInterpreter, line 238, in __call__
  Module TAL.TALInterpreter, line 281, in interpret
  Module TAL.TALInterpreter, line 728, in do_defineMacro
  Module TAL.TALInterpreter, line 281, in interpret
  Module TAL.TALInterpreter, line 457, in do_optTag_tal
  Module TAL.TALInterpreter, line 442, in do_optTag
  Module TAL.TALInterpreter, line 437, in no_tag
  Module TAL.TALInterpreter, line 281, in interpret
  Module TAL.TALInterpreter, line 780, in do_defineSlot
  Module TAL.TALInterpreter, line 281, in interpret
  Module TAL.TALInterpreter, line 457, in do_optTag_tal
  Module TAL.TALInterpreter, line 442, in do_optTag
  Module TAL.TALInterpreter, line 437, in no_tag
  Module TAL.TALInterpreter, line 281, in interpret
  Module TAL.TALInterpreter, line 728, in do_defineMacro
  Module TAL.TALInterpreter, line 281, in interpret
  Module TAL.TALInterpreter, line 749, in do_useMacro
  Module TAL.TALInterpreter, line 281, in interpret
  Module TAL.TALInterpreter, line 457, in do_optTag_tal
  Module TAL.TALInterpreter, line 442, in do_optTag
  Module TAL.TALInterpreter, line 437, in no_tag
  Module TAL.TALInterpreter, line 281, in interpret
  Module TAL.TALInterpreter, line 715, in do_condition
  Module TAL.TALInterpreter, line 281, in interpret
  Module TAL.TALInterpreter, line 715, in do_condition
  Module TAL.TALInterpreter, line 281, in interpret
  Module TAL.TALInterpreter, line 455, in do_optTag_tal
  Module TAL.TALInterpreter, line 437, in no_tag
  Module TAL.TALInterpreter, line 281, in interpret
  Module TAL.TALInterpreter, line 749, in do_useMacro
  Module TAL.TALInterpreter, line 281, in interpret
  Module TAL.TALInterpreter, line 339, in do_startTag
  Module Products.PlacelessTranslationService.PatchStringIO, line 158, in
patched_attrAction_tal
  Module Products.PageTemplates.TALES, line 227, in evaluateText
  Module Products.PageTemplates.TALES, line 221, in evaluate
   - URL: /luci/cluster/form-macros
   - Line 4579, Column 1
   - Expression: standard:'sinfo/root_uuid'
   - Names:
      {'container': <Folder at /luci/cluster>,
       'context': <Folder at /luci/cluster>,
       'default': <Products.PageTemplates.TALES.Default instance at 0x2aaab59e2ef0>,
       'here': <Folder at /luci/cluster>,
       'loop': <Products.PageTemplates.TALES.SafeMapping object at 0x11abd1b8>,
       'modules': <Products.PageTemplates.ZRPythonExpr._SecureModuleImporter
instance at 0x2aaab59e5680>,
       'nothing': None,
       'options': {'args': ()},
       'repeat': <Products.PageTemplates.TALES.SafeMapping object at 0x11abd1b8>,
       'request': <HTTPRequest, URL=https://taft-04:8084/luci/cluster/index_html>,
       'root': <Application at >,
       'template': <ZopePageTemplate at /luci/cluster/index_html>,
       'traverse_subpath': [],
       'user': <PropertiedUser 'admin'>}
  Module Products.PageTemplates.Expressions, line 185, in __call__
  Module Products.PageTemplates.Expressions, line 173, in _eval
  Module Products.PageTemplates.Expressions, line 127, in _eval
   - __traceback_info__: sinfo
  Module Products.PageTemplates.Expressions, line 320, in restrictedTraverse
   - __traceback_info__: {'path': ['root_uuid'], 'TraversalRequestNameStack': []}
KeyError: 'root_uuid'




Version-Release number of selected component (if applicable):
luci-0.10.0-3.el5
ricci-0.10.0-3.el5
Comment 1 Corey Marthaler 2007-08-06 15:45:36 EDT
I reproduce this on a non running service as well, in fact, rgmanager wasn't
even started at the time.
Comment 2 Ryan McCabe 2007-08-09 17:00:32 EDT
Do you happen to have the cluster.conf that was active at the time you saw this.
I've been trying to reproduce this bug, but I can't seem to hit it. Did it
happen all the time, and if so, with just that service, or with others, too?
Comment 4 Corey Marthaler 2007-08-17 16:55:50 EDT
I can't reproduce this bug with the lastest packages:
luci-0.10.0-4.el5/ricci-0.10.0-4.el5. 

Moving this off the proposed blocker list, and will close later if I still can't
reproduce it.
Comment 6 Corey Marthaler 2007-08-22 12:30:19 EDT
Closing, will reopen if seen again.

Note You need to log in before you can comment on or make changes to this bug.