Bug 250836 - Audit Seg Fault
Audit Seg Fault
Status: CLOSED DUPLICATE of bug 249759
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: audit (Show other bugs)
5.1
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Steve Grubb
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-03 16:55 EDT by Ian Marks
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 08:31:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Marks 2007-08-03 16:55:10 EDT
Description of problem:
Aureport & ausearch produce a segmentation fault

Version-Release number of selected component (if applicable):
audit-1.5.5-4.el5

How reproducible:
Executing either of the commands

Steps to Reproduce:
1. aureport -a
2. ausearch -m avc 
3.
  
Actual results:
#ausearch -m avc
Segmentation fault
#aureport
Segmentation fault


Expected results:


Additional info: This happened once I upgraded to 5.1.  I am running a
2.6.18-36.el5xen kernel
Comment 1 Steve Grubb 2007-08-03 17:27:44 EDT
This is likely to be a known problem and fixed in audit-1.5.5-5. This updated
package should be in snapshot #1. Do you mind re-testing when that package
becomes available?  Thanks.
Comment 2 Steve Grubb 2007-08-27 13:56:29 EDT
Hi...newer packages have been pushed into the beta channel. Do you still get a
segfault with new audit packages? Thanks.
Comment 3 Ian Marks 2007-08-30 11:41:58 EDT
I can't seem to find a later version from RHN, but audit-1.5.6-1 and audit-1.6-1
from your people.redhat.com/sgrubb site both worked correctly.
Comment 4 Steve Grubb 2007-09-10 08:31:47 EDT
I believe this bug was already fixed in snapshot #1 under bz 249759. I'm going
to mark this bug a duplicate of that one. If the bug returns, please let me
know. Thanks for reporting this issue.

*** This bug has been marked as a duplicate of 249759 ***

Note You need to log in before you can comment on or make changes to this bug.