Bug 250849 - webtraceback on rhn/WEB-INF/pages/user/create/createsatellite.jsp
webtraceback on rhn/WEB-INF/pages/user/create/createsatellite.jsp
Status: CLOSED DUPLICATE of bug 249694
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
501
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McCune
Brandon Perkins
na
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-03 17:31 EDT by wes hayutin
Modified: 2007-08-06 11:17 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-06 11:17:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2007-08-03 17:31:42 EDT
Description of problem:

webtraceback on rhn/WEB-INF/pages/user/create/createsatellite.jsp

I think I'm getting the traceback when users are created, howerver I am still
trying to determine the root cause..

Here is the traceback

The following exception occured while executing this request:
HEAD /rhn/WEB-INF/pages/user/create/createsatellite.jsp

Date:8/3/07 12:06:30 PM EDT
Headers:
  connection: TE, close
  host: fjs-0-12.rhndev.redhat.com
  te: deflate,gzip;q=0.3
  user-agent: lwp-request/2.06
  content-length: 0

Request:
Local Name = fjs-0-12.rhndev.redhat.com
Server Name = fjs-0-12.rhndev.redhat.com
Requested Session Id came from Url
Requested Session Valid = true
Session =
org.apache.catalina.session.StandardSessionFacade@20d0d6a3[session=StandardSession[2B600727DF66CF7F173C8ED53C9F89CB]]
Protocol = https
Request Locale = en_US
Request Character Encoding = UTF-8
Attribute Names = rhnActiveLang, javax.servlet.forward.request_uri,
javax.servlet.forward.context_path, javax.servlet.forward.servlet_path,
org.apache.struts.action.MESSAGE, javax.servlet.jsp.jstl.fmt.timeZone.request,
session, createSatelliteForm, __sitemesh__filterapplied, requestedUri,
countries, displaypam, org.apache.struts.action.mapping.instance,
availablePrefixes, org.apache.struts.action.MODULE, 


User Information:
No User logged in.

Exception:
java.lang.NullPointerException: charsetName
	at java.io.OutputStreamWriter.<init>(OutputStreamWriter.java:101)
	at javax.servlet.http.NoBodyResponse.getWriter(HttpServlet.java:916)
	at org.apache.jasper.runtime.JspWriterImpl.initOut(Unknown Source)
	at org.apache.jasper.runtime.JspWriterImpl.flushBuffer(Unknown Source)
	at org.apache.jasper.runtime.PageContextImpl.release(Unknown Source)
	at org.apache.jasper.runtime.JspFactoryImpl.internalReleasePageContext(Unknown
Source)
	at org.apache.jasper.runtime.JspFactoryImpl.releasePageContext(Unknown Source)
	at
org.apache.jsp.WEB_002dINF.pages.user.create.createsatellite_jsp._jspService(Unknown
Source)
	at org.apache.jasper.runtime.HttpJspBase.service(Unknown Source)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:237)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
	at
org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:704)
	at
org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:474)
	at
org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:409)
	at
org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:312)
	at org.apache.struts.action.RequestProcessor.doForward(RequestProcessor.java:1085)
	at
org.apache.struts.action.RequestProcessor.processForwardConfig(RequestProcessor.java:398)
	at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:241)
	at
com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:78)
	at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
	at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
	at javax.servlet.http.HttpServlet.doHead(HttpServlet.java:316)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:237)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
	at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:69)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
	at
com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
	at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
	at
com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:63)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
	at
com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:103)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
	at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:51)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
	at
com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:93)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
	at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214)
	at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
	at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
	at
org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:198)
	at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:152)
	at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
	at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137)
	at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
	at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:102)
	at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
	at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
	at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:929)
	at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160)
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:300)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:374)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:743)
	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:675)
	at org.apache.jk.common.SocketConnection.runIt(ChannelSocket.java:866)
	at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:683)
	at java.lang.Thread.run(Thread.java:570)
Comment 1 Brandon Perkins 2007-08-06 11:17:20 EDT

*** This bug has been marked as a duplicate of 249694 ***

Note You need to log in before you can comment on or make changes to this bug.