Bug 25089 - Crashes on Hard drive install..
Crashes on Hard drive install..
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: anaconda (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-27 14:05 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-01 16:50:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-01-27 14:05:56 EST
Here's the dump...this is from your Rawhide post dated 1/22/2001 , also 
its unable to make a bootdisk, I did a ftp install, and it will not make 
one. In addition, I keep getting "unable to write errors" when trying to 
write a bootdisk (mkbootdisk), states out of disk space, however, there is 
over 1gig free, on a WD 2.5gig IDE drive..any feedback needed..Just email, 
anf I will check back here also..Plus another concern, I try to do a 
hardrive install, the orig boot image is looking for an ISO image, which 
you are not posting, and will not install from a directory of the files
(pulled straight from you.). So I am using the boot image from 7.0..which 
is what is giving me this dump..Thanks



Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 503, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 1197, in run
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 401, in 
__call__
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1000, in 
upgradeFindPackages
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 619, in 
getCompsList
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 613, in 
getHeaderList
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/harddrive.py", line 161, 
in readHeaders
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/harddrive.py", line 101, 
in mountMedia
KeyError: 1

Local variables in innermost frame:
self: <harddrive.HardDriveInstallMethod instance at 81aa198>
cdNum: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'
p3
S''
sS'progressWindow'
p4
NsS'setupFilesystems'
p5
I1
sS'monitorVsync'
p6
S''
sS'videoCardStateNode'
p7
S''
sS'ddruidReadOnly'
p8
I0
sS'bootdisk'
p9
I0
sS'videoRamState'
p10
S''
sS'monitorOriginalName'
p11
S''
sS'language'
p12
(itodo
Language
(dp13
S'abbrevMap'
p14
(dp15
S'es_ES'
p16
S'Spanish'
p17
sS'tr_TR'
p18
S'Turkish'
p19
sS'sr_YU'
p20
S'Serbian'
p21
sS'de_DE'
p22
S'German'
p23
sS'sk_SK'
p24
S'Slovak'
p25
sS'ru_RU.KOI8-R'
p26
S'Russian'
p27
sS'is_IS'
p28
S'Icelandic'
p29
sS'no_NO'
p30
S'Norwegian'
p31
sS'sv_SE'
p32
S'Swedish'
p33
sS'en_US'
p34
S'English'
p35
sS'it_IT'
p36
S'Italian'
p37
sS'da_DK'
p38
S'Danish'
p39
sS'cs_CZ'
p40
S'Czech'
p41
sS'uk_UA.KOI8-U'
p42
S'Ukrainian'
p43
sS'hu_HU'
p44
S'Hungarian'
p45
sS'fr_FR'
p46
S'French'
p47
sS'sl_SI'
p48
S'Slovenian'
p49
sS'ro_RO'
p50
S'Romanian'
p51
ssS'font'
p52
(dp53
g37
S'lat0-sun16'
sg21
S'cyr-sun16'
sg27
S'cyr-sun16'
sg35
S'None'
sg25
S'lat2-sun16'
sg31
S'lat0-sun16'
sg33
S'lat0-sun16'
sg47
S'None'
sg49
S'lat2-sun16'
sg51
S'lat2-sun16'
sg23
S'None'
sg19
S'lat5-sun16'
sg45
S'lat2-sun16'
sg17
S'None'
sg43
S'cyr-sun16'
sg41
S'lat2-sun16'
sg39
S'lat0-sun16'
sg29
S'lat0-sun16'
ssS'langs'
p54
(dp55
g37
g36
sg21
g20
sg27
g26
sg35
g34
sg25
g24
sg31
g30
sg33
g32
sg47
g46
sg49
g48
sg51
g50
sg23
g22
sg19
g18
sg45
g44
sg17
g16
sg43
g42
sg41
g40
sg39
g38
sg29
g28
ssS'japanesehack'
p56
I0
sS'lang'
p57
g34
sS'tempDefault'
p58
S''
sS'map'
p59
(dp60
g37
S'iso15'
sg21
S'iso05'
sg27
S'koi8-r'
sg35
S'None'
sg25
S'iso02'
sg31
S'iso15'
sg33
S'iso15'
sg47
S'None'
sg49
S'iso02'
sg51
S'iso02'
sg23
S'None'
sg19
S'iso09'
sg45
S'iso02'
sg17
S'None'
sg43
S'koi8-u'
sg41
S'iso02'
sg39
S'iso15'
sg29
S'iso15'
ssS'info'
p61
(dp62
S'SUPPORTED'
p63
NsS'LANG'
p64
g34
ssbsS'instClass'
p65
(iinstallclass
DefaultInstall
p66
(dp67
S'rootPasswordCrypted'
p68
I0
sS'nameserver'
p69
S''
sS'x'
NsS'rootPassword'
p70
NsS'makeBootdisk'
p71
I0
sS'installType'
p72
NsS'postScript'
p73
NsS'earlySwapOn'
p74
I0
sS'networkDevice'
p75
NsS'clearText'
p76
NsS'lilo'
p77
(S'mbr'
p78
I1
S''
tsg12
S'en_US'
p79
sS'name'
p80
S''
sS'postInChroot'
p81
I0
sS'pixmap'
p82
S''
sS'partitions'
p83
(lsS'clearType'
p84
NsS'gateway'
p85
S''
sS'mouse'
p86
NsS'packages'
p87
NsS'timezone'
p88
NsS'zeroMbr'
p89
I0
sS'keyboard'
p90
S'us'
p91
sS'groups'
p92
NsS'bootProto'
p93
NsS'netmask'
p94
S''
sS'raidList'
p95
(lsS'skipSteps'
p96
(dp97
g90
I1
sg12
I1
ssS'auth'
p98
(I1
I1
I0
S''
I0
S''
I0
I0
S''
S''
I0
S''
S''
S''
I0
S''
S''
tsS'hostname'
p99
NsS'fstab'
p100
(lsS'showgroups'
p101
NsS'ip'
p102
S''
sS'firewall'
p103
(I-1
I0
(lp104
S''
I0
I0
I0
I0
I0
I0
tsS'defaultRunlevel'
p105
NsS'desktop'
p106
S''
sS'clearPartText'
p107
NsS'clearParts'
p108
I0
sbsS'bdstate'
p109
S''
sS'extraModules'
p110
(lp111
sS'rootpassword'
p112
NsS'fdDevice'
p113
S'fd0'
p114
sS'installSystem'
p115
I1
sS'comps'
p116
Nsg98
(itodo
Authentication
(dp117
S'useNIS'
p118
I0
sS'nisServer'
p119
S''
sS'useLdap'
p120
I0
sS'krb5Kdc'
p121
S''
sS'ldapTLS'
p122
S''
sS'useHesiod'
p123
I0
sS'ldapServer'
p124
S''
sS'nisDomain'
p125
S''
sS'krb5Realm'
p126
S''
sS'useLdapauth'
p127
I0
sS'hesiodRhs'
p128
S''
sS'useShadow'
p129
I1
sS'nisuseBroadcast'
p130
I0
sS'useKrb5'
p131
I0
sS'useMD5'
p132
I1
sS'ldapBasedn'
p133
S''
sS'krb5Admin'
p134
S''
sS'hesiodLhs'
p135
S''
sS'hesiodDlhs'
p136
S''
sbsS'users'
p137
NsS'hdList'
p138
NsS'dhcpState'
p139
S''
sS'method'
p140
(iharddrive
HardDriveInstallMethod
p141
(dp142
S'fstype'
p143
S'vfat'
p144
sS'mediaIsMounted'
p145
I0
sS'fnames'
p146
(dsS'isoDirIsMounted'
p147
I1
sS'isoDir'
p148
S'/tmp/isodir/'
p149
sS'path'
p150
S'//i386/'
p151
sS'device'
p152
S'hdd6'
p153
sS'tree'
p154
NsS'discImages'
p155
(dsS'messageWindow'
p156

<failed>
Comment 1 Michael Fulbright 2001-01-30 16:46:46 EST
Assigning to a developer.
Comment 2 Erik Troan 2001-01-30 16:47:52 EST
7.0 boot images won't work with rawhide; you have to use 7.1 images (and in this
case, make the proper iso images)
Comment 3 Need Real Name 2001-01-30 21:07:23 EST
This takes care of the install issue, But the issue about not being able to 
create bootdisk is still unanswered!!! I did an FTP install, and it is still 
unable to make a successful boot disk...I know this has been closed. Just not 
answered fully.
Comment 4 Erik Troan 2001-01-30 22:12:29 EST
You have module mismatches all over the place because you're using the wrong
kernel. In particular, you don't have loopback devices, and you're missing
filesystems.
Comment 5 Need Real Name 2001-01-30 23:32:28 EST
Clarity..The ftp install was a clean install from the 
rawhide /pub/rawhide/i386...It works fine, but I am still unable to make a 
bootdisk from that install..Thats when I attempted to install from the hard 
drive (ftp'ed directory on another drive) I use Norton Ghost to make images of 
installs. A dedicated drive for Linux..At any rate..I was jsut trying to figure 
out why I was unable to make a successful boot disk..I can install v7.0 fine 
and make bootdisk, or the Mandrake version of v7.0..I was just puzzled why 
unable to make a successful boot disk from a clean install..I would try using 
the HD method, but looking for format of ISO image..don't think 
"You have module mismatches all over the place because you're using the wrong
+kernel. In particular, you don't have loopback devices, and you're missing
+filesystems." is valid..Only kernel in question is version 2.4.0-0.99.5, from 
the rawhide distro dated 1.22.01 I believe...Thanks


Comment 6 Erik Troan 2001-02-01 16:50:05 EST
You said you used an install boot disk from 7.0. That won't work with 7.1.

Note You need to log in before you can comment on or make changes to this bug.