Bug 250899 - hiccups while dist-upgrade
hiccups while dist-upgrade
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-doc-utils (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-04 15:32 EDT by Chitlesh GOORAH
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 17:52:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chitlesh GOORAH 2007-08-04 15:32:33 EDT
Description of problem:
during yum install firefox --enablerepo=development, I have :
Transaction Check Error:
  file /usr/share/pkgconfig/gnome-doc-utils.pc from install of 
gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/pkgconfig/xml2po.pc from install of 
gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/common/db-chunk.xsl from install of 
gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/common/db-common.xsl from install of 
gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/common/db-label.xsl from install of 
gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/common/db-title.xsl from install of 
gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/common/db-xref.xsl from install of 
gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-autotoc.xsl from install 
of gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-bibliography.xsl from 
install of gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from 
package gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-block.xsl from install 
of gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-callout.xsl from install 
of gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-classsynopsis.xsl from 
install of gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from 
package gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-cmdsynopsis.xsl from 
install of gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from 
package gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-css.xsl from install of 
gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-division.xsl from 
install of gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from 
package gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-ebnf.xsl from install of 
gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-footnote.xsl from 
install of gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from 
package gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-funcsynopsis.xsl from 
install of gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from 
package gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-info.xsl from install of 
gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-inline.xsl from install 
of gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-l10n.xsl from install of 
gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-list.xsl from install of 
gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-media.xsl from install 
of gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-qanda.xsl from install 
of gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-refentry.xsl from 
install of gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from 
package gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-suppressed.xsl from 
install of gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from 
package gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-table.xsl from install 
of gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-title.xsl from install 
of gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html-xref.xsl from install of 
gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/html/db2html.xsl from install of 
gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/docbook/omf/db2omf.xsl from install of 
gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/gettext/gettext.xsl from install of 
gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/gettext/l10n-numbers.xsl from install of 
gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6
  file /usr/share/xml/gnome/xslt/gettext/l10n.xml from install of 
gnome-doc-utils-stylesheets-0.11.1-1.fc8 conflicts with file from package 
gnome-doc-utils-0.8.0-2.fc6

Version-Release number of selected component (if applicable):
gnome-doc-utils-0.8.0-2.fc6

It seems that there was a package split.
Can you update the spec so that the update go smooth in development 
repositories? thus users who are performing dist-upgrade might not their yum 
stroking.
Comment 1 Matthew Barnes 2007-08-04 21:29:44 EDT
Try removing gnome-doc-utils-0.8.0-2.fc6.
Comment 2 Chitlesh GOORAH 2007-08-05 07:26:43 EDT
Removing gnome-doc-utils, it's fine.
However, yum should _not_ stroke like this for other users.
Comment 3 Chitlesh GOORAH 2007-08-05 10:27:53 EDT
By closing this bug, you mean you won't fix it ?
You can't obsolete gnome-doc-utils in the spec file.
Take a look how the KDE sig is doing for KDE4, they are obsoleting parts of 
KDE3 in the development branch.

Note You need to log in before you can comment on or make changes to this bug.