Bug 250912 - rhn api not working since 5.0.2
Summary: rhn api not working since 5.0.2
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site   
(Show other bugs)
Version: RHN Stable
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Grant Gainey
QA Contact: Amy Owens
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-05 03:28 UTC by Tsai Li Ming
Modified: 2008-01-29 14:14 UTC (History)
1 user (show)

Fixed In Version: 5.0.4.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-29 14:14:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tsai Li Ming 2007-08-05 03:28:17 UTC
Description of problem:
The published api links no longer works, as noted in the rhn mailing list too
https://rhn.redhat.com/rpc/api

As a result, the xmlrpc endpoint does not work too. 

Version-Release number of selected component (if applicable):


How reproducible:
Just use the above the url. 

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
The api link viewed by the browser should bring you to the api docs. Using
xmlrpc post, the api methods should be reachable and not return a xmlrpc fault. 

Additional info:

Comment 1 Amy Owens 2008-01-29 14:14:31 UTC
when I click on the above link, I get redirected here:
https://rhn.redhat.com/rhn/apidoc/index.jsp.. If this is still an issue please
let us know.


Note You need to log in before you can comment on or make changes to this bug.