Bug 250936 - Segfaults on startup
Segfaults on startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compat-wxGTK26 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Michael Schwendt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-05 14:09 EDT by Tom London
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-06 04:38:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom London 2007-08-05 14:09:04 EDT
Description of problem:
Get this when starting audacity:
[tbl@localhost ~]$ audacity
Gtk-Message: Failed to load module "gnomebreakpad": libgnomebreakpad.so: cannot
open shared object file: No such file or directory

(audacity:7711): Gtk-CRITICAL **: gtk_widget_ensure_style: assertion
`GTK_IS_WIDGET (widget)' failed
Segmentation fault
[tbl@localhost ~]$

Running with gdb:

[tbl@localhost ~]$ gdb audacity
GNU gdb Red Hat Linux (6.6-22.fc8rh)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
Using host libthread_db library "/lib/libthread_db.so.1".
(gdb) run
Starting program: /usr/bin/audacity 
[Thread debugging using libthread_db enabled]
[New process 7750]
[New Thread -1208846640 (LWP 7750)]
Gtk-Message: Failed to load module "gnomebreakpad": libgnomebreakpad.so: cannot
open shared object file: No such file or directory

(audacity:7750): Gtk-CRITICAL **: gtk_widget_ensure_style: assertion
`GTK_IS_WIDGET (widget)' failed

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208846640 (LWP 7750)]
0x02d5b574 in ?? () from /usr/lib/libwx_gtk2u_core-2.6.so.0
(gdb) where
#0  0x02d5b574 in ?? () from /usr/lib/libwx_gtk2u_core-2.6.so.0
#1  0x02d5c995 in wxSystemSettingsNative::GetColour ()
   from /usr/lib/libwx_gtk2u_core-2.6.so.0
#2  0x0806eddc in AColor::Init () at AColor.cpp:224
#3  0x0807bf4c in AudacityApp::OnInit (this=0x9263fc8) at AudacityApp.cpp:381
#4  0x0807d321 in wxAppConsole::CallOnInit (this=0x9263fc8)
    at /usr/include/wx-2.6/wx/app.h:87
#5  0x051eee10 in wxEntry () from /usr/lib/libwx_baseu-2.6.so.0
#6  0x051eeef6 in wxEntry () from /usr/lib/libwx_baseu-2.6.so.0
#7  0x08078600 in main (argc=Cannot access memory at address 0x0
) at AudacityApp.cpp:189
#8  0x005ab0b0 in __libc_start_main () from /lib/libc.so.6
#9  0x0806df21 in _start ()
(gdb) 



Version-Release number of selected component (if applicable):
audacity-1.3.2-14.fc7


How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2007-08-05 14:32:46 EDT
Loaded debuginfo package and reran gdb:

[tbl@localhost ~]$ gdb audacity
GNU gdb Red Hat Linux (6.6-22.fc8rh)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
Using host libthread_db library "/lib/libthread_db.so.1".
(gdb) run
Starting program: /usr/bin/audacity 
[Thread debugging using libthread_db enabled]
[New process 16155]
[New Thread -1208437040 (LWP 16155)]
Gtk-Message: Failed to load module "gnomebreakpad": libgnomebreakpad.so: cannot
open shared object file: No such file or directory

(audacity:16155): Gtk-CRITICAL **: gtk_widget_ensure_style: assertion
`GTK_IS_WIDGET (widget)' failed

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208437040 (LWP 16155)]
0x02d5b574 in GetTooltipColors () at src/gtk/settings.cpp:150
150         GdkColor c = tooltips->tip_window->style->bg[GTK_STATE_NORMAL];
(gdb) where
#0  0x02d5b574 in GetTooltipColors () at src/gtk/settings.cpp:150
#1  0x02d5c995 in wxSystemSettingsNative::GetColour (index=wxSYS_COLOUR_INFOBK)
    at src/gtk/settings.cpp:276
#2  0x0806eddc in AColor::Init () at AColor.cpp:224
#3  0x0807bf4c in AudacityApp::OnInit (this=0x8afffc8) at AudacityApp.cpp:381
#4  0x0807d321 in wxAppConsole::CallOnInit (this=0x8afffc8)
    at /usr/include/wx-2.6/wx/app.h:87
#5  0x051eee10 in wxEntry (argc=@0xbf97d140, argv=0x8ad6608)
    at src/common/init.cpp:423
#6  0x051eeef6 in wxEntry (argc=@0xbf97d140, argv=0xbf97d1c4)
    at src/common/init.cpp:451
#7  0x08078600 in main (argc=Cannot access memory at address 0x0
) at AudacityApp.cpp:189
#8  0x005ab0b0 in __libc_start_main () from /lib/libc.so.6
#9  0x0806df21 in _start ()
(gdb) 
Comment 2 Michael Schwendt 2007-08-05 15:58:53 EDT
> Gtk-CRITICAL **: gtk_widget_ensure_style: assertion
> `GTK_IS_WIDGET (widget)' failed

> gtk_widget_ensure_style(tooltips->tip_window);
> GdkColor c = tooltips->tip_window->style->bg[GTK_STATE_NORMAL];

This is since gtk2 2.11.6 where the GtkToolTips API is deprecated.
Also see:

wxGtk uses private API, breaks with gtk 2.11.6
http://sourceforge.net/tracker/index.php?func=detail&aid=1767485&group_id=9863&atid=109863
Comment 3 Michael Schwendt 2007-08-05 16:03:37 EDT
wxGTK 2.8.x is affected, too.
Comment 4 Michael Schwendt 2007-08-06 04:38:03 EDT
compat-wxGTK26-2.6.3-5 will work around this (hopefully
only temporarily).

The new GtkTooltip API hides internal structures, so porting
the old code that accessed private members might not be possible.

Note You need to log in before you can comment on or make changes to this bug.