Bug 250979 - Setroubleshoot ought to require libuser
Summary: Setroubleshoot ought to require libuser
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: John Dennis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 433166 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-06 09:37 UTC by Göran Uddeborg
Modified: 2008-02-17 18:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-09 19:14:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Göran Uddeborg 2007-08-06 09:37:48 UTC
Description of problem:
Setroubleshoot, /usr/lib/python2.5/site-packages/setroubleshoot/signature.py to
be precise, imports libuser.  This is provided by the libuser package, but
setroubleshoot doesn't require libuser.  And python imports are not handled
automatically by RPM, as is done for perl.

Version-Release number of selected component (if applicable):
setroubleshoot-1.9.4-2.fc7

Additional info:
Only special configurations will not have libuser installed, so most systems do
not risk hitting this problem.  But to be correct, the requirement ought to be
there.

Comment 1 John Dennis 2007-08-09 19:14:23 UTC
Thank you for taking the time to report this. It is fixed upstream now and
should appear in the next released rpm.

Comment 2 Fedora Update System 2007-08-27 21:43:18 UTC
setroubleshoot-1.10.1-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 3 John Dennis 2008-02-17 18:04:49 UTC
*** Bug 433166 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.