Bug 25098 - initscripts-5.55-1, /etc/rc.d/init.d/network is missing a pipe
Summary: initscripts-5.55-1, /etc/rc.d/init.d/network is missing a pipe
Status: CLOSED DUPLICATE of bug 24674
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-27 23:20 UTC by rodrigc
Modified: 2014-03-17 02:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-27 23:20:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description rodrigc 2001-01-27 23:20:36 UTC
The script:
/etc/rc.d/init.d/network is missing a pipe.
This causes the script not to work, and network interfaces are not started.

Here is a diff to correct the problem:
--- network.old Sat Jan 27 17:27:18 2001
+++ network     Sat Jan 27 17:27:37 2001
@@ -35,7 +35,7 @@
 # find all the interfaces besides loopback.
 # ignore aliases, alternative configurations, and editor backup files
 interfaces=`ls ifcfg* | egrep -v '(ifcfg-lo|:|rpmsave|rpmorig|rpmnew)' | \
-           egrep -v '(~|\.bak)$' \
+           egrep -v '(~|\.bak)$' | \
             egrep -v 'ifcfg-ippp[0-9]+$' | \
             egrep 'ifcfg-[a-z0-9]+$' | \
             sed 's/^ifcfg-//g'`

Comment 1 Bill Nottingham 2001-01-29 03:14:52 UTC

*** This bug has been marked as a duplicate of 24674 ***


Note You need to log in before you can comment on or make changes to this bug.