Bug 251015 - udev does not load thinkpad_acpi
udev does not load thinkpad_acpi
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
7
i686 Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
: 251769 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-06 10:52 EDT by Edmond Hui
Modified: 2014-03-16 23:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-25 11:10:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Edmond Hui 2007-08-06 10:52:01 EDT
After upgrade to kernel 2.6.22-* thinkpad_acpi is not loaded for Thinkpad T60,
which caused GNOME senor applet to fail.

Please see this bug report for detail
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=250013
Comment 1 Chuck Ebbert 2007-08-10 18:04:33 EDT
According to Bug 250013, this is a udev problem. The module got renamed as part
of the update to kernel 2.6.22. Can we solve that with some change to the kernel
RPM?
Comment 2 Harald Hoyer 2007-08-13 03:51:52 EDT
udev problem? udev had no special handling of thinkpad_acpi.
maybe modprobe.conf? alias?
Comment 3 Chuck Ebbert 2007-08-13 11:32:05 EDT
This is that awful hack in initscripts [/etc/rc.d/rc.sysint] biting us again:

# Initialize ACPI bits
if [ -d /proc/acpi ]; then
    for module in /lib/modules/$unamer/kernel/drivers/acpi/* ; do
        module=${module##*/}
        module=${module%.ko}
        modprobe $module >/dev/null 2>&1
    done
fi


In 2.6.20 kernels we have:

drivers/acpi/
  ac.ko
  asus_acpi.ko
  battery.ko
  button.ko
  dock.ko
  i2c_ec.ko
  ibm_acpi.ko
  sbs.ko
  toshiba_acpi.ko
  video.ko

2.6.22 has:
  ac.ko
  battery.ko
  bay.ko
  button.ko
  dock.ko
  sbs.ko
  toshiba_acpi.ko
  video.ko

And in drivers/misc:
  asus-laptop.ko
  eeprom_93cx6.ko
  ioc4.ko
  msi-laptop.ko
  sony-laptop.ko
  thinkpad_acpi.ko
  tifm_7xx1.ko
  tifm_core.ko

asus-acpi was renamed to asus-laptop and moved from acpi/ to misc/.
ibm_acpi was renamed to thinkpad_acpi and also moved.

Looks like we never did load msi-laptop even though it was in 2.6.20 all along,
and now there's also a new sony laptop driver as well. And the toshiba driver is
still in acpi/.

FC6 is has this problem too.

Comment 4 Chuck Ebbert 2007-08-13 11:53:32 EDT
*** Bug 251769 has been marked as a duplicate of this bug. ***
Comment 5 Bill Nottingham 2007-08-29 13:13:39 EDT
thinkpad_acpi has dmi aliases. This should be loaded somehow through udev.
Comment 6 Roberto Marquardt 2007-09-25 10:56:17 EDT
(In reply to comment #4)
> *** Bug 251769 has been marked as a duplicate of this bug. ***

There might be two different bugs. Here is what I observe:
# modprobe /lib/modules/2.6.22.5-76.fc7/kernel/drivers/misc/thinkpad_acpi.ko
FATAL: Module /lib/modules/2.6.22.5_76.fc7/kernel/drivers/misc/thinkpad_acpi.ko
not found.
# insmod /lib/modules/2.6.22.5-76.fc7/kernel/drivers/misc/thinkpad_acpi.ko
insmod: error inserting
'/lib/modules/2.6.22.5-76.fc7/kernel/drivers/misc/thinkpad_acpi.ko': -1 Unknown
symbol in module
Same errors with kernel 2.6.22.4-65.fc7.
Could it be that the modules are not in order?
I am interested in solving this bug because I need to access the external
display on my lenovo x61s running under Fedora7 (almost everthing but the extra
keys work).
Comment 7 Bill Nottingham 2007-09-25 11:10:51 EDT
Roberto - you have a different issue.

Try just 'modprobe thinkpad_acpi'. If that fails, and you have a supported
device, it's a kernel bug.

As for the modules, the acpi section has been removed from initscripts - all the
appropriate modules have proper DMI or ACPI aliases, and therefore should load
automatically.

Note You need to log in before you can comment on or make changes to this bug.