Bug 251029 - [RHEL5] gtk-extrafuncs.defs missing from pygtk2-devel
Summary: [RHEL5] gtk-extrafuncs.defs missing from pygtk2-devel
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pygtk2   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Matthew Barnes
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-06 16:36 UTC by Orion Poplawski
Modified: 2013-04-12 19:18 UTC (History)
0 users

Fixed In Version: RHBA-2008-0079
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-23 13:59:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0079 normal SHIPPED_LIVE pygtk2 bug fix update 2008-01-30 15:13:20 UTC
GNOME Bugzilla 380020 None None None Never

Description Orion Poplawski 2007-08-06 16:36:13 UTC
+++ This bug was initially created as a clone of Bug #217430 +++

Description of problem:

While trying to compile plplot:

pygtk-codegen-2.0 --prefix cplplotcanvas --register
/usr/share/pygtk/2.0/defs/gdk.defs --register /usr/share/pygtk/2.0/defs/gtk.defs
--register /usr/share/pygtk/2.0/defs/gnome.defs --register
/usr/share/pygtk/2.0/defs/canvas.defs --override
/builddir/build/BUILD/plplot-5.7.1/bindings/gnome2/python/cplplotcanvas.override
/builddir/build/BUILD/plplot-5.7.1/fedora/bindings/gnome2/python/plplotcanvas.defs
> /builddir/build/BUILD/plplot-5.7.1/fedora/bindings/gnome2/python/cplplotcanvas.c
Traceback (most recent call last):
  File "/usr/share/pygtk/2.0/codegen/codegen.py", line 1707, in ?
    sys.exit(main(sys.argv))
  File "/usr/share/pygtk/2.0/codegen/codegen.py", line 1665, in main
    p.startParsing()
  File "/usr/share/pygtk/2.0/codegen/scmexpr.py", line 114, in startParsing
    self.handle(statement)
  File "/usr/share/pygtk/2.0/codegen/scmexpr.py", line 118, in handle
    getattr(self, cmd)(*tup[1:])
  File "/usr/share/pygtk/2.0/codegen/defsparser.py", line 29, in include
    self.startParsing()
  File "/usr/share/pygtk/2.0/codegen/scmexpr.py", line 114, in startParsing
    self.handle(statement)
  File "/usr/share/pygtk/2.0/codegen/scmexpr.py", line 118, in handle
    getattr(self, cmd)(*tup[1:])
  File "/usr/share/pygtk/2.0/codegen/defsparser.py", line 33, in include
    raise IOError("%s not found in include path %s" % (input_filename, inc_path))
IOError: gtk-extrafuncs.defs not found in include path
['/usr/share/pygtk/2.0/defs', '.']

Version-Release number of selected component (if applicable):
pygtk2-devel-2.10.1-8.el5

The include is coming from ../root/usr/share/pygtk/2.0/defs/gtk-base.defs:

(include "gtk-extrafuncs.defs")

-- Additional comment from mbarnes@redhat.com on 2006-11-27 23:57 EST --
Turns out this was not a packaging bug as I had originally thought.

Forwarding this upstream along with a patch.  Please refer to:
http://bugzilla.gnome.org/show_bug.cgi?id=380020

Fixed in pygtk2-2.10.3-5.fc7.

-- Additional comment from orion@cora.nwra.com on 2006-11-30 18:00 EST --
Can a fix be released for FC6 too?

-- Additional comment from mbarnes@redhat.com on 2006-11-30 19:21 EST --
Sure, also fixed in pygtk2-2.10.3-3.fc6.

Comment 5 Matthew Barnes 2007-12-17 23:11:14 UTC
Fixed in pygtk2-2.10.1-11.el5

Comment 8 errata-xmlrpc 2008-01-23 13:59:45 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0079.html



Note You need to log in before you can comment on or make changes to this bug.